New error with Roborock integration

I’m getting this error all of a sudden:

Logger: homeassistant.setup
First occurred: 10:42:31 PM (1 occurrences)
Last logged: 10:42:31 PM

Setup failed for custom integration roborock: Unable to import component: cannot import name 'async_process_integration_platform_for_component' from 'homeassistant.helpers.integration_platform' (/usr/src/homeassistant/homeassistant/helpers/
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/", line 215, in _async_setup_component
    component = integration.get_component()
  File "/usr/src/homeassistant/homeassistant/", line 818, in get_component
    ComponentProtocol, importlib.import_module(self.pkg_path)
  File "/usr/local/lib/python3.11/importlib/", line 126, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "<frozen importlib._bootstrap>", line 1204, in _gcd_import
  File "<frozen importlib._bootstrap>", line 1176, in _find_and_load
  File "<frozen importlib._bootstrap>", line 1147, in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 690, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 940, in exec_module
  File "<frozen importlib._bootstrap>", line 241, in _call_with_frames_removed
  File "/config/custom_components/roborock/", line 20, in <module>
    from homeassistant.helpers.integration_platform import (
ImportError: cannot import name 'async_process_integration_platform_for_component' from 'homeassistant.helpers.integration_platform' (/usr/src/homeassistant/homeassistant/helpers/

I tried to uninstall the integration, but it didn’t uninstall it.

What is the problem exactly?

Get the latest version of the integration through HACS, it is fixed on my end


Thank you. it helped.

1 Like

Worked here also… TY