New ESPHome version unable to access my devices


I updated ESPHome to the new version (2021.12.1). But now I am unable to see the logs of my devices. They still work fine, but I would like to be able to run OTA or logging in the future.

All my devices are build with firmware 1.20.4. When I open the log I get an black screen, see screenshot. I can only access these devices wireless, so i am not able to test if the log still works via usb.


Thanks for you help!

Roll back to backup wait for fix. There is a problem with the new version.

The new version was 2021.12.2, that had problems and was removed. Is that the version you installed? 12.1 should work.

No i have 12.1 installed

I’ve read a few threads now that mention that even 12.1 has some issues. I’ve avoided upgrading that yet until things settle down.

1 Like

Umm, I have rolled back to 1.20.4 but still my logs and black. Could there be another reason?

Did you update all the nodes to 12.1 when you updated or did you just update the addon?

I see you didn’t do the nodes, looks like the next step would be to remove and reinstall. Are you familiar with the process?

I am afraid am I not. I just did the add-on and I did not update my devices, they are still on 1.20.4. But somehow with ESPHome back on 1.20.4 I still cannot access them. What is the process?


First try a different browser/machine and clear your cache on the machine you used when you got the error. Make sure it’s not just in the browser now.

Technically you should just be able to remove and reinstall and everything should restore itself. Besides the HA backup, I like to backup the esphome folder. It contains all your node .yaml files. In the config folder you will see the esphome folder.

I’d restart the supervisor in between remove and reinstall. Because it saves its settings that may not work. If it doesn’t, follow the above but rename the esphome folder to esphome.old.

Then inside /config/.storage you will see esphome text files. Cut and paste any esphome files into the esphome.old folder. Then remove and reinstall. If all goes well you can safely delete esphome.old

Hi Mikefila, thanks. But no luck, I have re-installed ESPHome and are now on version 12.1. Logs on nodes are still black and suddenly several notes are offline now… Should I just wait for an updated ESPHome version?


Did something happen to your back-up of 1.20.4 that you reinstalled the newer version? The reason to remove everything was to ensure that no files were left behind from 12.1.

There is also about 6 months difference between the your node firmware and 12.1. I’m wondering if the log output is related to the nodes not being updated. Do you have a spare esp that you could test flash with updated firmware and see if the log output is visible?

I tried a new node and I get a black screen too.

The backup of 1.20 is gone? Have you tried to reinstall the backup after removing the esphome folder and files?

I was able to use Edge browser to run logs and updates … then went back to Chrome. There is a delay of several minutes before logs or updates show anything in the screen in Chrome. I did this without regressing from HA 2021.12.7

Hi JPA, thanks for the suggestion; tried but no luck. I guess I have to wait for the next ESPHome update?

Was hoping that version 12.3 would resolve my issue, but it seems it doesn’t. Other ideas?