New HA install does not have User account and is missing features

Hi, I have installed HA onto a QNAP TS-453D using the process described by ninko here:

Basically I now have Home Assistant 0.65.5 running via Docker. However when I logged into it via port 8123 it did not ask me to create a user account.

So a big question would be - why didn’t I get asked to create an account? I can now log in and use it without entering a password. HA is running but is missing some important options that are talked about in the documentation, like integrations and which obviously reduces functionality quite a lot. The attached file shows the main options that I do have.

I feel like I must have missed something key and obvious here, and internet people tend to be good at letting you know when you’ve done that. Can anyone let me know where I’ve gone wrong here?

The log file seems to be only struggling with things that haven’t been set up yet, e.g. a sensor and accessing my Google account. The tts directory is empty and seems to be missing an initialization file so perhaps that is relevant.


Because 0.65.5 is older than God and the new auth system didn’t exist back then…

1 Like

That version is over a year old. Maybe try to upgrade to 0.114.1 :slight_smile:

Ahhh. I was wondering about the discrepancy there. So I must have somehow found a very old source. Perhaps it was the most popular install file.

Ok, great. Problem solved! Thanks guys.

Could I ask you how to solved it due to I meeet smae problem.