New HA setup on Pi4 Doesn't Work [Solved]

So once I flash the SD card HA loads fine once I change my config file and restart the front end doesn’t load anymore. However, I can successfully SSH into HA but no matter what I do the front end doesn’t load. I even used InPrivate browsing incase cashing the web is issue didn’t help. Any ideas?

Did you do a config check before restarting.

Since you have SSH access. Check the log, see if there is an error preventing startup.

I did check Config, it doesn’t show any error. Log only shows that it can’t connect to insteon due to authentication error.

This is a brand new install. I have flushed a new install three times even with no modification once I restart, front UI doesn’t load anymore.

I even checked the ip address on my unifi.

Can you share more info ?
Share your configuration.yaml file ? python version ? virtual environment or not ? version of HA ?
Did you try to remove the modification made to the config files to restore the initial config ?
Have you checked the status of the HA service :

$ sudo systemctl status <your home assistant service>

Thank you so much for your help. Well Config file is unmodified. Everything is the latest image file available on HA website. I am running it on RPi 4. There are no errors in Homeassistant logs. What is the user/pass of local hassio? I have tried to log into hass os using my ssh user/pass doesn’t seem to work to check the status

Is there a way I can downgrade to previous versions?

I never used/installed, so no experience with this environment… I am running HA in a virtual environment on a Pi4… To downgrade, I read on “Installing” webpage that you have to run:

hassio ha update --version=0.XX.X

Check the requirements on this page:
or wait for more help from the community… good luck !

Awesome, just out of curiosity. What is the advantage of running the HA instant on virtual machine. Is it more stable?

I do not think it is more or less stable as I am not using it I cannot give some feedback… It is just that I do not like to be constraint in a “all in one” solution… I prefer to manage the operating system, applications, tools and add on separately… So probably less convenient than and requiring more work to maintain the correct software versions (like Python) but I have the feeling that I can better control (or disrupt… :slight_smile: ) the environment… On my rapsberry Pi, on top of HA I am also running my network monitoring (Nagios) with Apache and SSL encryption… So I choose at the beginning to run HA in a virtual environment.

Thanks for the insight man. So an update to hassos solved the issue. I think the previous version wasn’t really compatible with Pi 4