New Hass.io images, based on HassOS


#306

I had to restore after the mess that was 79.0 and the repositories weren’t automatically added this time, however all the third party add-ons were. They’ve definitely changed something.


#307

Hi,
are you able to install aeon z stick gen5 on HASSIO, and how do you do ?. Only hassio.
Or, end with HASSIO and start with hassbian.


#308

Yes, check your HW configuration and add the lines to your configuration.yaml file.

zwave:
  usb_path: /dev/ttyACM0

You can check your HW config from Hassio > System > Host System > Hardware
On a Pi3, Mine shows both AMA0 and ACM0, I have always used ACM0.

When you go to add devices, do not remove the zwave stick and use the button, but instead, use the HomeAssistant menu "Configuration > Zwave "to add nodes. If you are using zwave plus devices and want secure connections, then you also need to set your network key and select the “add node secure” option.

  • serial:
    • /dev/ttyAMA0
    • /dev/ttyACM0

#309

Just wanted to say thanks – I also got this when I moved from ResinOS to HassOS (and from a 16GB SD Card to a 64GB SD Card and from a Pi 3b to Pi3b+) and it messed up a bunch of things, including the configurator add-in and all my input value selects.

The configurator would run for a while and then crash – looking at the Pi HDMI out it ran out of memory and HassOS killed it.

I eventually deleted the home_assistantv2.db file via SSH and now everything seems fine (except AppDaemon, but will probably be able to fix that).


#310

can anyone help i had hass.io on a pi2 but trying to upgrade to a pi3 b+, i have used etcher to flash the image but every time i plug the sd card in to the pi i get a solid red light and the green light flashes 3 times every few seconds.

Nath


#311

Which image did you pick? The 32bit is the recommended version. Also, when Etcher finishes, just have it eject the card, since you won’t be able to read most of the partitions anyway.


#312

i done exactly that fella, and when i plug it in i get a boot page and it says no ethernet even tho its hardwired


#313

Sorry, I was hoping for something simple… :slight_smile: . The only other suggestion I tripped across was to try a different SD card. A lot of us have had good luck with the Samsung EVO line, at least 32GB.

One change I made recently on a new build was to mount the first partition of SD card (/dev/sdc1 in my case) and edit the config.txt file. This let me disable wifi and also force the HDMI output to VGA mode, because the monitor I have for the odd occasion is ancient…

dtoverlay=pi3-disable-wifi

# uncomment if you get no picture on HDMI for a default "safe" mode
hdmi_safe=1

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_group=2
hdmi_mode=16

#314

ah poo, no need for apologises fella appreciate the help in any form.
Was hoping it was gonna be plug and play like it was for the 2 but proving not or im doing something proper stupid.