New Hass.io images, based on HassOS


#286

Ok so I got a USB boot working for Hassio.

I have a Pi3B (not a 3B plus)

I installed the latest Raspbian Stretch image on a USB and booted from it and then I used Dale3h’s script which installs Docker and then installs the Hassio container and the Supervisor container. I restored my snapshot and it was all working except for a couple of things I needed to do.

  1. change the ssh port from 22 to something else. You will still be able to use port 22 to ssh into the host.
  2. I needed to uninstall and reinstall the configurator addon - I’m using the one in Daniels own repo as it is kept better up-to-date than the official repo.
  3. I needed to uninstall and reinstall Daniel Welsh’s Dropbox backup addon. Neither configurator or dropbox would start till I did that!

Dale3h’s script can be found here:

If you login on port 22 (to the host) you will find all the config files at /usr/share/hassio/homeassistant
If you login on ssh port in addon, you will find everything in the ‘right’ place anyway.

I haven’t timed it but I think it’s a fair bit faster.

I am also noticing a database error so I’m going to delete the database and restart.

Note this is NOT running HassOS or ResinOS it’s running Raspbian and Hass.io

EDIT: I just deleted the database and restarted. It took less than a minute!
Also I’m currently running 0.76.0b3 with the new auth and also legacy_api and lovelace.


#287

I flush the hassos on my Mac by Etcher. But looks like can’t boot it up, tried several different versions. Is there anyone encounter similar issue?

If I plug to the monitor, here is what I see.

IMG_1017.jpg


#288

Are you wired or wireless?

PS it has obviously booted. You do realise it takes anywhere from 20 minutes to a couple of hours to download and install home assistant?


#289

have you tried connecting to http://ip-address:8123 ?
what are you expecting to see in a ssh session?


#290

It’s wired. Really, it’s booted? I can’t access the HA page for now. Anyway, I will wait and check later.


#291

I was not able to connect to IP:8123. SSH was refused.


#292

the web interface will show the HA logo for a bit but it will go blank/dead and will then load the GUI. You aren’t going to see anything interesting on the ssh screen.
don’t connect using ssh!!!

use your web browser. type in ip address:8123

you do not ssh to port 8123


#293

Of course it has booted. What do you think generated all that text? A poltergeist?


#294

There are some issues with power supply on HassOS. My system boots, too, but I can’t connect to UI and Hass is not running. Check my other thread.


#295

It’s there any method that I can download the old resinos?


#296

See my post here which has a link to it

Link


#297

Any news regarding GPIOs on HassOS? Meanwhile updated to 1.10 and still edge detection is failing for RPi-RF Addon.


#298

I am not sure whether this is related to GPIO issues, but I can’t get PiFace to work.

Logs:

Error during setup of component rpi_pfio
Traceback (most recent call last):
  File "/usr/local/lib/python3.6/site-packages/homeassistant/setup.py", line 148, in _async_setup_component
    component.setup, hass, processed_config)  # type: ignore
  File "/usr/local/lib/python3.6/concurrent/futures/thread.py", line 56, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/usr/local/lib/python3.6/site-packages/homeassistant/components/rpi_pfio.py", line 25, in setup
    pifacedigital = PFIO.PiFaceDigital()
  File "/usr/local/lib/python3.6/site-packages/pifacedigitalio/core.py", line 82, in __init__
    self.init_board()
  File "/usr/local/lib/python3.6/site-packages/pifacedigitalio/core.py", line 107, in init_board
    h=self.hardware_addr, b=self.bus, c=self.chip_select))
pifacedigitalio.core.NoPiFaceDigitalDetectedError: No PiFace Digital board detected (hardware_addr=0, bus=0, chip_select=0).

Detected hardware:

* serial:
  * /dev/ttyACM0
  * /dev/ttyAMA0
* input:
* disk:
* gpio:
  * gpiochip100
  * gpiochip0
  * gpiochip128
* audio:
  * 0:
    * name: bcm2835_alsa - bcm2835 ALSA
    * type: ALSA
    * devices:
      * 0: digital audio playback
      * 1: digital audio playback

Config.txt:

kernel=u-boot.bin
disable_splash=1
dtparam=audio=on
dtparam=spi=on

Host: HassOS 1.10
Supervisor: 128
Hass: 0.77.1


#299

Would it be worth adding to the blog post that you should manually add additional add-on repositories before restoring backup, if you want those add-ons to be restored?


#300

No, because you don’t!


#301

Huh. They didn’t add to the restore until I added the repositories to a freshly booted install, and then restored?


#302

That has happened to me when I restored a HassOS snapshot on A Debian system and might have happened when I changed from 32bit to 64bit but it’s not normal to need to do it.


#303

Not sure what was the issue, my hassio was very slow after the new update. Now i am on rasbian and the worst part is i cant install hassos inside it.If anyone could help me on virtual machine installation on raspbian and running hassos ? need your inputs please


#304

I had to do this today after migrating to HassOS.


#305

I have also had to do this before when I have restored snapshots but I just moved to HassOS and the snapshot from resinos installed everything. Boot time is definitely longer on hassos - just over 5 minutes for me. Log shows various add-ons and services taking over 10 seconds to load. Http site feels very responsive.