New HASS user with a few questions

Hey all!
I took the plunge into HASS over the weekend and things seems to be going alright for the most part, but I have a few questions that I’m hoping someone might be able to help out with.

First, I’m running HASS on a Raspberry Pi and I have a Gen 5 Z-Stick. I’ve got it configured and it’s picked up my z-wave light bulb, but the led on the z-stick is driving me nuts. Is there any way to have the light not cycle from red to orange to blue all the time? If so, this would be amazing.

Second, it seems HASS is having some issues either triggering and/or knowing the state of my devices. Right now I’m trying to control a z-wave light bulb and a GE Link (zigbee) bulb through a Wink “Link” hub (two bulb starter kit was on clearance at my local Home Depot for $20. Figured it couldn’t hut to give it a shot). I’ve got both devices setup, HASS acknowledges them, and I’m able to turn them on/off.

When clicking the on/off button the toggle switches, the light takes the appropriate action, but the toggle goes back to it’s original state. Example: Bulb is on. I click the toggle to turn it off. Toggle switches to off position and quickly back to on position. Bulb turns off. I checked the HASS log and nothing is showing up for either device. I pulled the open z-wave log, which is here, but I’m not really seeing anything. Anyone happen to have any ideas about what is going on with the toggles?


I use Wink Hub component very heavily and do not see that very often. I notice that when I do see it that it seems to correlate with heavy load on the HASS side and tends to correct itself within less than 30 seconds. I’m sorry that I don’t have an answer, but wanted to let you know what I see.

Thanks! I appreciate your input. Strange thing is… I’m seeing it for both z-wave and the link hub. I only have 3 devices setup at the moment so my config is fairly minimal. I wouldn’t think the load would be very heavy, but a possibility.

From Amazon… have yet to try it myself…

5.0 out of 5 starsHere is how to disable the annoying disco light (Was: Amazing Z-Wave Stick for Rasperry Pi)
ByAkhon May 30, 2016
Verified Purchase
Folks, here is how you disable the annoying flashing disco LED light:

Step 1: Get a Windows machine
Step 2: Download Drivers for the USB stick from the official website and follow their instructions
Step 3: Download CoolTerm (it is free)
Step 4: Plug-in the USB stick. CoolTerm should immediately recognize it as a COM-port. Mine is COM3
Step 5: In CoolTerm, click “Connect”. Now you are connected to your USB Z-stick via Serial interface
Step 6: In CoolTerm menu: Go to “Connection” -> “Send String…”
Step 7: Pick “Hex” radio button and copy/paste the following command
01 08 00 F2 51 01 00 05 01 51
Step 8: Click “Send”
Step 9: Disco is over!

If you want to re-enable the Disco send the following command on Step 7:
01 08 00 F2 51 01 01 05 01 50

This solution is taken from Domoticz forum […]

Below is my review of the stick itself:

Works great with Home Assistant + Raspberry Pi 3 (with Raspbian) + Minimote and SmartSwitches

A few notes for Raspberry Pi hackers:

  • follow the installation instructions on the home assistant website carefully. You should be comfortable with command-line at the very least. There are a few places where they recommend setting up hass inside python virtualenv instead of root. I would recommend doing that. Worked well for me
  • it is trivial to add SmartSwitches and almost any device you can think but there is one device that will be more tricky:
  • minimote: both the Z-stick and minimote are controllers. The stick would need to become the primary controller and minimote must become a secondary controller. Please google for it: there are instructions in the internet (see that work with Home Assistant. It worked for me.