New Hassbian Installation not working


#1

Hi guys,

Recently started using HA with Hassi.io, but found it too restrictive, so decided to install Hassbian. Downloading the latest image however and it’s not working.

After installing and logging in via Putty, it comes up that HA services is inactive. Doing a command line restart and then status, it comes up with the following:

[email protected] - Home Assistant for homeassistant
   Loaded: loaded (/etc/systemd/system/[email protected]; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Thu 2019-03-14 11:21:45 UTC; 1min 13s ago
  Process: 808 ExecStart=/srv/homeassistant/bin/hass (code=exited, status=203/EXEC)
 Main PID: 808 (code=exited, status=203/EXEC)

I’ve re-downloaded the image three times now. I’ve also gone back to a Hass.io install to make sure it wasn’t the SD card - that worked fine. Is the current image possibly corrupted? This is on a Pi 3 B+ connected via ethernet.


#2

I have not used Hassbian, but assuming you can login, try this

sudo systemctl enable home-assistant
sudo systemctl start home-assistant

It appears that the home-assistant service is disabled and not started. Enabling it permits it to start automatically after a reboot.


#3

usually when you look at the status there is additional lines of logs below what you posted above. Does it say anything else?

also can you open the configuration folder (usually at /home/homeassistant/.homeassistant by default - at least it used to be…) and check the homeassistant.log file to see if it gives any errors there?


#4

If you find that the web page is not reachable after 30 minutes or so, check that you have files in /home/homeassistant/.homeassistant/ , if there are no files in this location then run the installer manually using this command: sudo systemctl start install_homeassistant.service .