New Ikea Somrig button, not able to connect zha

Hello :slight_smile:
I bought the new Ikea Somrig buttons and would like to connect them to my HomeAssistant with Zigbee Dongle.
During the search of a new device, HA identifies the button but is not able to configure it. Is anybody aware if there is a way to connect a device which is currently not fully supported or do you know if there will be an integration?


Although the configuration process does not finish, the device is part of the device list. Sometimes there is a battery and identify entity and sometimes not. I can not control any entity.

1 Like

You can make a device support request.

1 Like

Also bought today. Win also make a feature request.

I just got it work, thanx to casperz at github.
You have to add his custom ZHA quirk (config file) to your system. Download it from here (be careful to download it “raw”, just right clock on the “raw” button on the right side of the header and “save as” or similar)

to apply a custom quirk:

  1. install samba share addon if you have not already
  2. create a folder named /custom_zha_quirks under /config
  3. save this downloaded .py file here
  4. activate using custom quirks by addind this code to configuration.yaml:
zha:
  enable_quirks: true
  custom_quirks_path: /config/custom_zha_quirks/
  1. restart HA
  2. add the somrig to ZHA
1 Like

Hi all,
It works for me with ZHA. I have needed to pair it many times before button 1 works.
Does anyone have a blueprint for this switch ?

It must be said that the Somrig has a much worse latency than the older Tradfri dimmer switch. A single press iniates two actions in sequence:
“Initial Switch Press - Button 1” and shortly after “Remote Button Short Press - Button 1”
Even if I trigger actions with the first event, it is significantly slower as the old nice Tradfri :frowning: I is a shame it is not distributed any more.

1 Like

I have also observed this.
I recently bought a Vallhorn, PARASOLL and the Somrig. After much trial and error and some research, I no longer buy Ikea zigbee devices. AAA batteries are not an advantage when the reliability is gone

Has anyone got this to work using two of these SOMRIG devices?

The first one after doing this work around worked with out issues but the second is now sticking at the configuration stage as it did before the I put this in.
Update:
I have now worked out how I got this to work. I paid it with a repeater rather than the controller and it then worked…

For me, using 1.2V batteries helped.

So basically similar issue as with the Valhorn motion detector, that gave false detections when using basic 1.5V AAA batteries.