New install, need help!

Installed on a RPi3B+ with direct network connection (sort of).
I say sort of because my service provider in all their wisdom removed all but one internet port from their modems. So I have a switch connected to that and everything connected to the switch.
The Pi is connected and shows up with an IP but I can not connect to Home Assistant. It took some time for it to show if that makes a difference.
Are there some further steps i can take at this point?


How are you trying to connect?

Which IP addresses have you tried?

http :white_check_mark: ? or https :x: ?

It sounds like your internet modem is in bridge mode, which means that everything is forwarded to one IP address and that IP address is all you have from the service provider.
This setup is usually for people using their own router.

So you should probably get your own router or hear the ISP if the modem can be set to router+NAT mode instead.

Thanks for the reply.
I am using http:// to connect

Thanks for the reply.
Correct me if I’m wrong but aren’t most home users connecting with their service providers modem and only have one IP? My modem like most is a modem and router combo. The switch is being used because my provider doesn’t recommend a router be used as this would require the modem be in bridge mode. I will of course dig deeper into this. I mean I can not see the good part of the country not being able to use Home assistant on the biggest provider there is here in Canada simply because of their modems being used.

As far as I know my modem is not in bridge mode.

The typical consumer connection would be a modem router combo running with the router function enabled and providing NAT features also.
The limit of one internet port is though typical for a modem router combo set in bridge mode.

Bridge mode is used when the consumers wants to handle the routing themself or avoid the extra routing at all, which would mean one server only.
The ISP provided router is often a low powered router that can not really handle the bigger bandwidth of modern connection and certainly not when you start to add firewall rules and VPN services to it on top of the routing.

And the rest…

if this is the case. Whats the work around?

Are you using http://<ip_address>:8123 ?

Well, if it is in bridge mode, then decide to go with bridge mode and place your own device behind or you can choose to switch to router mode, which the ISP might be able to help you with, if you do not have access the routers configuration pages.

Bridge mode is not really a problem that needs a work around. It is a feature you should be happy to have, since it open possibilities, and its rare that router mode is not provided as an option from the ISP too.

yes i am using it just like that

I fairly certain its not in bridge mode. A few days ago I had an issue accessing the modem (App based) and had to reset. After the reset it was not broadcasting either wifi. The first thing the tech asked is did i change to bridge mode. So likely its not in bridge mode. The wifi had somehow turned off completely. lol
Edit: Got into it and def not in bridge mode.


Good, now that you are in can you then check DHCP leases to see if HA has pulled an IP address?

Ok so got a connection i can now see but it never completes the install. I have tried reformatting and loading the files back on the SD card so many times at this point, I lost count.
What could this be caused by?

This is where it seems to like to stop and just hang out.

[s6-init] making user provided files available at /var/run/s6/etc…exited 0.
[s6-init] ensuring user provided files have correct perms…exited 0.
[fix-attrs.d] applying ownership & permissions fixes…
[fix-attrs.d] done.
[cont-init.d] executing container initialization scripts…
[cont-init.d] executing…
[15:29:06] INFO: Using udev information from host
[cont-init.d] exited 0.
[cont-init.d] done.


And there is no webpage on the IP address of HA with :8123 behind?

It has the blue Preparing Home Assistant screen. I click the blue dot and its just sitting there doing nothing.

Finally got it working.
Turns out it did not like my SD card. Got a new one and it booted up and grabbed all my devices which was very nice.
Now to learn how to use and set it all up.

Thank you everyone

Yeah, SD Card corruption is a sort of necessary evil when using them. That is the reason why you see solutions to back your configuration up to Github or Google Drive and why SSD solutions to Raspis are so talked about.

Will def be looking at an ssd upgrade. I never trust memory cards and yes backups are a def necessity