New installation on VirtualBox

Outside the VM. You can do either docker or linux (assuming you have docker in Fedora).

Ok thanks. Will try that.

Not sure if you guys tried but I had terrible issues like you describe when first migrating from HyperV to VBox (to get the USB passthrough). I had the same thing, get everything setup and working and then boom, wouldn’t work. Had to scrap and redo things 3 times. Turns out that using VBox while anything HyperV is enabled caused my issues. I disabled all HyperV stuff (like 2 or 3 checkboxes) in the Programs and Features settings and it’s been working flawlessly in VBox since! If you look at the OPs screenshots; the 10th one down has the little turtle next to all the other icons in the bottom right corner, that’s an indication that you have HyperV enabled and VBox is not running as it should be.


Hi all, new to HA. I was trying to set a static IP for my HA which is running in a VB in a Win Laptop. I was following the simple instructions provided here I think I have messed up something and tried to reset the changes that didn’t go well as-well. Now when I run “nmcli” or “nmcli con show” I don’t see “HassOS default” anymore. I see “Wired connection 1”. and I can not browse HA any more. Any help any one? Thanks.

The Virtualbox version gets it’s IP address from the host, ie the win laptop.

Hi, thanks for your reply. but how do I reset the network back to default, if you know? I don’t see “HassOS default” anymore as I stated earlier.

I would assume you should set the file back to the default

yes I was checking that part, but not sure where and how to put the default preinstalled connection profile.

Also there is a section in that page “Reset network”. I can’t run the 2nd command, gives me “cd: can’t stat …”

Thanks! Turns out this second IP address from the DHCP allowed me to access the webGUI.

1 Like

@hjanum, I have almost the same setup as you do, and I tried to run HASSIO … but without success.
I believe it has something to do with VirtualBox … cos after about 1 minute of booting … I get the following error log:

00:01:14.657399 ERROR [COM]: aRC=VBOX_E_NOT_SUPPORTED (0x80bb0009) aIID={13a11514-402e-022e-6180-c3944de3f9c8} aComponent={GuestWrap} aText={Invalid status level defined: 0}, preserve=false aResultDetail=0

Which version of VBox have you install? Mine is 6.1.14


I followed the same guide that most everyone else seems to have done for VirtualBox v6.1.14 using the current HASSOS build v5.3. VM acquired an address via DHCP, but no response from the browser. So I went to the command prompt. It let me log in, but immediately produced:

panic: runtime error: index out of range [0] with length 0

Then a call stack and a complaint that the HA CLI was not running.

I’m on 5.4 using VirtualBox 6.1.12 because after updating to 6.1.14, I wasn’t able to get USB passthrough to see my HUSBZB-1 dongle. Anyone else have similar experiences?

My windows PC uses link aggregation. I got everything setup but I’m stuck at:

this can take up to 20 minutes

Wonder if it’s a network issue

What can take 20 minutes?

This, no matter what I do it’s stuck for hours. I tried several installs already.

In virtualbox there is a terminal. Can you ping an address on the internet?

I was using an old hassio image all works now with latest image.

1 Like

I find the reboot time to be slower than my pi3/ssd config.

I am running this on a AMD FX-8350 (OC to 4.4Ghz) with 8GB DDR3 ram. Dedicated 2GB of RAM and 4Cores to my VM.

And once it loads Hassio, it takes a few minutes longer to load my Zwave devices (aeon labs zw090 z-stick gen5 usb stick). I’ve added this USB under the device filters.

I’m having the same issue. What image did you use to get it to work?