New installation on VirtualBox

I am having an issue with my fresh install on VirtualBox. The host is a Win10 Pro 64bit OS. I have about 300Gb of free disk space when starting the install.

I have tried following various guides in getting this running, but I can’t seem to get the virtual machine off the ground. Any help would be appreciated. This is pretty much a vanilla install, so I am not sure what is going on.

First I download the VDI file from here:

I add the disk Virtual Media Manager and update the size to 100Gb.

Here is the disk updated.

I create a new virtual machine:
image

I update the memory to 2Gb (2048Mb)
image

I select “Use an existing virtual hard disk file”:
image

Under Settings->System I enable “EFI”

I assign two processors:

Under Settings->Network I change the network adapter to “Bridged” and Promiscuous Mode is set to Allow All

Here are the resulting settings:

I then start the virtual machine, but even after waiting an hour it seems to get stuck here.

My understanding is that it is supposed to be downloading and installing the newest version, but there has been very little network traffic on the virtual machine.

The virtual machine did get an IP address assigned by my UniFi network.
image

It is not listening on port 8123 yet though.

I did the same a while ago on an Ubuntu host without problems.

I tried
Auswahl_339
and increased the size of the disk after the first installation.

Don’t know if that helps, give it a try.

Thank you for your suggestion. I had not tried generic Linux for machine type.

I created a new virtual machine with the same Linux version as you and I did not resize the disk before starting the VM. I also tried to reduce the machine to the default one processor.
image

The machine then gets stuck about 52 seconds into the process. After that there is no network, CPU or disk activity. I left it running for about half an hour.

It does not respond to port 8123
image

I try to send an ACPI Shutdown to the machine after about half an hour.
It shuts down ‘normally’. I then restart it. It runs for a while and then reboots after multiple log messages. I did not see any errors. After that I get the following screen.
image

I wonder if there is a new default setting in VirtualBox that needs to be changed. I have looked through all installation instructions/videos I could find. The install does not seem to work with the current version of HA and VirtualBox.

1 Like

That’s odd.
What happens when you hit ‘Enter’ in the VM console?
Do you get a login prompt?


If yes, i assume VBox has network issues on Windows 10.

Here are the settings i have.

Ignore the two network adapters, it’s only a test VM that should not access my network.

I had the same issue when running the latest version of virtualbox 6.1.8.
I downgraded virtualbox to 6.1.4-136177 and was able to get the vm booted fully.

I tried downgrading to virtualbox 6.1.4, but that install got stuck as well. Hitting enter does not bring up the login screen, so I think I am stuck.

There are new images with HassOS 4.8 since yesterday.
The next you can try. :crossed_fingers:

I spent a few days trying to get the HassOS 4.8 image running on VirtualBox 6.1.8. I still have not found a working set of settings for the VM. I think the next thing to try is to move to my Unbutu VirtualBox host instead of using the Windows 10 Pro host to see if that makes a difference.

I do basically the same thing as you, with the same Host (Windows 10 pro), ubuntu64 as the virtual machine OS, and mine works. I definitely had more issues with the last version of the HassOS image but 4.8 seems to be better. Try following this video guide EXACTLY in the same order he does it and see if you are successful.

Edit: This video is a little dated, some of the versions of things have changed but the order of operations is still valid.

Edit 2: Sorry, skip to 4:02 in the video, that’s when he starts talking about the virtual box install.

I’ve had no end of issues with my HassOS in virtualbox. Annoyingly, it’ll work fine for awhile, just long enough for you to have invested time and effort in getting everything perfect and then it’ll randomly die. Refuse to boot. Or only boot on every 10th attempt. Seeing the screenshots above gave me PTSD. “failed to start docker application container engine”… followed by the 4 boot option menu. Grrr…

I have previously blamed HassOS, but I suspect it’s something finicky between my hardware, virtual box and the OS.

In the last few hours I’ve moved across to hyper-V. It’s certainly much, much quicker on loading and once I figured out that I had to add a new network connection in “virtual switch manager” it was pretty easy. Might be worth a try?

The other thing I learnt today was if you’ve been a bit slack with extracting your snapshots from the system, “Diskinternals Linux Reader” - a free windows app, can be used to mount and extract snapshots or even just config.yaml files from a dead virtualbox vdi.

I’ve been struggling to get my VirtualBox VM off the ground for weeks. I have a similar setup as you … Win 10 Pro, new hardware. I’ve tried all kinds of scenarios, researched and researched, each time getting the a failure to boot. Then I decided on a whim to try my same default HA VM setup on another computer and it started up with no problem. That leads me to believe that at least in my situation there is something in the BIOS or hardware config that is preventing the VM boot. So now I’m going to compare BIOS setting between the 2 machines. I know that on the PC that wouldn’t start the VM I have every security option I could think of turned on, so I may have to back some of those down.

I spent so much time troubleshooting the config\etc. Unfortunately I can’t find any documentation about hardware\BIOS\Windows settings restrictions for VirtualBox.

Hope this helps.

Did you figure out your VirtualBox issue? I spent wasted most of the day today moving from Hyper-V to VirtualBox because I wanted to get USB passthrough support. Could not initially get the VirtualBox VM to boot and after a couple hours of screwing around, finally figured out that Hyper-V doesn’t play nice with other VM solutions on the same machine. Disabled Hyper-V in Windows Features, and my VirtualBox VM started up just fine. If you have Hyper-V enabled, you may want to look at that. My only gripe with VirtualBox so far is that it takes much much longer for the VM to start and get to the point where I can see the HA gui - 3.5 minutes from starting up the VM to fully see my HA gui.

I did solve my problem.

SITUATION:
A new PC build of Asus Z490 mobo, Intel core-i7, 32GB RAM, 500GB SSD, Windows 10 Pro 64bit. I used Oracle VirtualBox VM software following the instructions on the HA website as well as the video here https://youtu.be/sVqyDtEjudk (Home Assistant Beginners Guide - 2020). I was generous with my VM specs and gave it 2 CPUs and 4GB RAM.

PROBLEM:
The VM would start but before getting very far would stop with the message “Starting ms-dos executable …”. I googled the executable and it was a Linux kernel file.

I worked on this problem for weeks. Found no help on either the HA forum or other online sites. I was about to give up.

SOLVED:
As I stated in an earlier post, I copied my VM to another PC and it started up all the way. This led me to believe that it was a PC setup issue. My new build (spec above) I went to some effort to make as secured as possible, both in the BIOS settings and in Windows. I was striving to achieve Windows Device Security to say “Standard hardware security supported”, which I did achieve. This included Core Isolation and Security Processor. Within Core Isolation I enabled Memory Integrity.

It was the Memory Integrity that was preventing my VM from booting up. My 2nd PC (the one that the VM did boot on) had this setting disabled. As soon as I disabled it on my new build the VM took off and booted up all the way.

image

Hi all,

today I had the same problems with my freshly installed hassio on Virtualbox 6.1
I’m also using Bridge Mode.
The VM started without any problems and I could connect the ha console by using user “root” with empty password but I couldn’t connect to the VMs Home Assistant web application using port 8123.
The cmd in the ha shell “core info” returns an IP 172.30.32.1
I assume that this IP is an IP which is internally used by docker.
In my router I found my PC twice with two IPs. One of them was the IP of my PC which it gets from the DHCP server of my router. The other IP was the one for my HA VM.
When using this IP:8123 I could finally connect to HA via my browser.

Good luck with HA !

i was in the same position today.

i had a total different ip address you should check it on the VM doing:

>login: root
ha> login
# nmcli

there will be the “HassOS default” connection properties, so you can check the ip address.

This can now be done from within the GUI. Supervisor -> System -> Host System (IP Address) and select ‘Change’

OK, for the OP I think he should try using a different network emulation setting in VBox. One of the Intel ones works.

Make it bridged (you already have that).

Then the HA instance will have the same IP address as the host PC and HA is found on that IPAddress:8123.

Noob here so I need to ask a very basic question.

I have installed Home Assistant via the official .vmdk file from (https://www.home-assistant.io/hassio/installation/) in VirtualBox running on a Fedora 25 system.

I need to install AWS-CLI (https://docs.aws.amazon.com/cli/latest/userguide/install-cliv2.html) but I don’t know which path to follow. Is my install a straight Linux install or a Docker install?

The next related question is do I install AWS-CLI from within the VM console (i.e. ‘root’ followed by ‘login’) or on the host system itself?

You shouldn’t install software inside the HA image.

Hmm. So what does that mean? Is mine a Linux install or a docker install and based in what you say would I install AWS-CLI outside the VM?