New installation problems

I tried using fing, and the information it produced in a HTML file was this

BODY { FONT-SIZE: 12px; FONT-FAMILY: Tahoma } STRONG { COLOR: dimgray; FONT-FAMILY: Tahoma } TD { FONT-SIZE: 11px; FONT-FAMILY: Tahoma; COLOR: black} A { FONT-SIZE: 11px; COLOR: darkslategray; FONT-FAMILY: Tahoma; TEXT-DECORATION: none } #UP { } #DOWN { background: #FFBBBB } .HEADER { width: 100%; FONT-SIZE: 12px;} .DISCOVERY { width: 100%; border: 0px; background: gray; border-collapse: separate; border-spacing: 1px; *border-collapse: expression('separate', cellSpacing = '1px');} .DISCOVERY TR { background: white } .DISCOVERY TH { background: #dadada; FONT-SIZE: 12px}
2017/09/03 13:03:44 overlook fing v3.0 [Refresh Page]
Discovery report of network - 4/4 hosts up

State Host MAC Address Vendor Hostname Last change
UP D4:40:F0:64:09:C8      
UP FC:F5:28:FB:D6:BF      
UP EC:71:DB:A3:B3:E9      
UP 3C:77:E6:68:98:37   DESKTOP-IF9OG3C.lan  

2017/09/03 13:03:44 overlook fing [Refresh Page]

The easiest way would be ping hassbian.local

However, it sounds like it could just be that it’s still starting up and installing. As long as you didn’t reboot it in the middle of that, you’ll just have to wait up to 30 minutes.

From the documentation:

If you find that the web page is not reachable after 30 minutes or so, check that you have files in /home/homeassistant/.homeassistant/, if there are no files in this location then run the installer manually using this command: sudo systemctl start install_homeassistant.service.

it actually said in all the text that comes up the IP address “my IP address is 192.1 68.1.23”
so I tried

Try, not https.

If it hasn’t worked after half an hour, follow the guide in the documentation I linked to.

It wasn’t working, so I thought I would re-burn the SD card. Don’t know why, change my mind and installed the hassio version.

Waited a while, and put in the normal
no joy.

However when I put in;
I got the image in the original documentation instructions telling me to wait for installation.

It has now finished loading, and it is asking me for a password. Just tried;
but the circle is just going round and round and saying loading.

ETA if I press F5 it goes back to the login page

Any advice appreciated, Tremulous Tetra. :slight_smile:

I did try the information in the link 1st. is very different, pick a single install option and stick with it. If you don’t then it’s impossible to help you.

If you’re using then SSH isn’t available by default, it’s managed through the GUI.

as it is the latest version, and the one I tried 1st, and the one I’ve had the most success with, I would prefer to stick with I only tried the other one as I was getting nowhere originally with the latest one.

I cannot get into the user interface because okay, managed to get hassio to load properly.however when I put in; asks me to login have tried raspberry as the password, any other ideas?

having said that, which in your opinion is the easiest for a complete idiot like myself? :slightly_smiling_face:

I tried Ping hassbian.local( I did correct the spelling)but I didn’t get the correct IP address. What am I doing wrong this time? :smiley: :smiley: :smiley:

“It depends” :wink:

The hass io approach gives you an appliance like experience, with less ability to change things. Hassbian gives you more control and flexibility. There’s no right answer, it’s about personal preference (which is why I went with a base operating system on my Pi, and then used the All In One approach).

That said, hass io is new, so there are less people with experience to help you. I’d probably suggest Hassbian if you want it simple, or AIO if you want to know your OS is working first. The latter approach will take a bit longer, but it’s easier to know what’s going on.

As for that login screen, that’s expecting the API password, which I don’t believe is supposed to be set at that point.

well, I am getting nowhere with the other 2 approaches. Stuck with it asking for password.that said I would prefer the version which involves the least amount of typing. On my PC I can use speech recognition. So from that criteria, I guess the IO version would be the best.

So I will startagain another day. Getting tired now.

Thanks for all your help.

Any advice appreciated, Tremulous Tetra. :slight_smile:

No worries. If you get stuck next time around, make sure you post in the section so folks know what you’re using.

Will you have a look at the ping question above, where I’m going wrong, because I’m sure the IP address will change tomorrow.

That looks to be a Barefruit IP address, doing an “error resolution” service. It’s either a piece of software you installed, or something your ISP does by default.

When you’ve done your next re-install, or decide to stick where you are, you need to ensure you set up a static DHCP lease for your Pi. How you do that depends on what’s handing out your DHCP leases - though some cheap ISP routers don’t have that capability.

OMG even going to
and copying the command
“$ curl -O && sudo chown pi:pi && bash”
results in;
error failed to execute child process “$” (no such file or directory)

Don’t start with the $, it’s an indicator that you’re typing a command.

Lots of people get tripped up by it, you’re not alone.

The same issue, using HA for the first time & using a Pi for the first time no one knows what to expect. After the screen just goes black it is normal to assume something went wrong.

Installed Hassbian this morning it worked fine. Now its just gone again - restarted the pi and have the HA logo again. Does this go away after it installs and updates only leaving a black screen i.e. you cant do anything with Pi anymore or does it provide the same usability as Rassbian minus resources used for HA.?

Is you installed Hassbian then you should be able to log in locally (though normally you’d SSH in).

If you installed then the logo won’t go away.