New installation problems

I followed the instructions here
plugged the raspberry Pi 3 into the television, and could see the pale blue home assistant on the screen.
Hardwired the raspberry Pi to the home network.
The Internet seems to be working, as you can see the light flashing.
the keyboard and mouse are both connected to the raspberry Pi, but do not appear on the screen in any fashion.
When you try to connect to http://hassio.local:8123/ , I constantly get the message

Cannot reach this page
•Make sure the web address http://hassio.local:8123 is correct
•Search for this site on Bing
•Refresh the page
More information More information
Fix connection problems

I have tried rewriting the pie 3 software to 2 SD cards.

Any advice appreciated, Tremulous Tetra. :slight_smile:

How long did you wait?

On first boot, it downloads the latest version of Home Assistant which takes ~20 minutes (slower/faster depending on the platform).

It has been on for ages. The screen just goes black.

Is that the correct image? That appears on my screen?

Should I be able to do anything with the mouse and the keyboard plugged in?

And the raspberry Pi does work with the normal raspberry Pi operating system.

Can you access with the IP?

First things first, I just put the raspberry operating system back on, and was able to surf the Internet, so the Internet is working.

I’m not sure, for some reason, the homeio is downloading software. I’m going to rewrite the software on the SD card, and see what happens.

Did you even read the instructions because as @Tinkerer pointed out, that is what it literally says…

yes, that is literally what it says. You write the software to the SD card using the program, plug it into the raspberry Pi, and the first time you “run it downloads the latest version of home assistant”. The problem is, I don’t think it is downloading. There seems to be a discrepancy between the image on my television;
and this image from the installation instructions.

I have just rewritten the software onto the SD card. Placed it in the raspberry Pi and rebooted. After about 5 minutes the screen goes black. Tapping on the keyboard or moving the mouse does not wake it up.

so I left it on for hours. Exactly the same problem.

What I am trying to ascertain is;
am I correct about the discrepancy between the images? When people install this do they see the image that is on my screen, or the image that is on the installation guide?

Any advice appreciated, Tremulous Tetra. :slight_smile:

Yes, I also tried putting in the IP address. It wouldn’t contact.

Any advice appreciated, Tremulous Tetra. :slight_smile:

Open any computer in your home network (or smartphone), go onto your browser and type the address (http://hassio.local:8123) , you should see the second screen in the browser.
If you know the IP adress of the RPi on your local network you may also use it like this
( Just replace the ip with the one of your Pi

What you have on your tv is because the RPi is wired directly to the tv

no, when I click on your link the only thing on my browser is this

I don’t know what the IP address of the raspberry Pi is.

Any advice appreciated, Tremulous Tetra. :slight_smile:

You could try to install hassbian instead of hassio, and see if the problem persists…

try downloading it from here;

he gets to the end of loading and then asked me for a password;


just tried the version 1.23,same problem, asking for login (yes this is the username) then password

The default username (as explained here) is pi, with the password as raspberry.

Thanks very much for your perseverance.

Ok, that doesn’t seem to work either.

Loaded the 1.23 version onto the SD card. It scrolls through the usual date of information on the screen. Come straight to the login (in the instructions it says it will install in the background home assistant, and then you will be able to contact you through your browser) when I put the password in, fine it works, I just pressed PI and then enter. When I press the key to put the word raspberry in, nothing appears on the screen, no letters no stars no nothing. When I press enter, it tells me they they are the wrong login details.

So I left it for 15 minutes, to see if I could reach it from the browser on my computer typing in;
After initial boot an installer will run in the background and takes around 15 minutes to complete, after it has finished you can reach Home Assistant in your browser at http://hassbian.local:8123. If you want to login via SSH, the default username is pi and password is raspberry (please change this by running passwd).

My hands are paralysed, so I will have to wait for someone to help me, but I am going to try and plug this raspberry Pi stray into the roots of instead of the wired connection I am using at the moment. See if that helps.

Any advice appreciated, Tremulous Tetra. :slight_smile:

Unix type systems don’t echo passwords on the command line, so that’s normal.

Make sure though you enter them exactly as I showed them, they have to be all lower case.

1 Like

Oh, okay. This time I was able to change the password.

However, http://hassbian.local:8123 still gives the same response, That the page cannot be found.

I am using Windows 10. What is the easiest way to find out the IP address of the raspberry Pi?