New installation Raspberry PI 4 SSD Failed

I have Home Assistant running in a virtual box already. I’m trying to switch over to a Raspberry Pi 4b 4GB and install Home Assistant on a SSD drive. The Raspberry PI is connected to a switch with an ethernet cable. My router has given it an ip address of I have followed some tutorials and I can boot from the SSD drive. As Home Assistant is booting up, I see a failed message on one line (figure 1). Once it hits the 1:30 seconds, it continues to boot up and displays the the words “Home Assistant” (figure 2). When I try to connect to the Pi, I get a message stating it cannot connect. I have tried this with 2 SSD drives and an SSD card. All fail at the exact same spot and cannot connect.

(figure 1)

(figure 2 - I borrowed someone else’s picture)

In another post, someone was having a very similar issue, except they were using a virtual machine. Someone said the op of that post should use the following command.

Adjusted for my network:
I know the “enp2s1” needs changed to match my Rasp Pi. I am just not sure what that is at this moment.

net update enp2s1 --ipv4-method static --ipv4-address --ipv4-gateway --ipv4-nameserver

My questions are, will that fix my issue and, if it does, why is it not picking up the ip from my router?

How long are giving it, it can take up to 20 minutes, although normally a bit quicker on a Rpi4, That second pic looks like it has started fine. But once you see that screen it can take a while before it boots to the web interface. Try if you haven’t already.

I suspect that systemd-time-wait-sync.service starts too soon and that there is no internet connection available yet. I’ve had something similair when I tried to make it run as a Tor hidden service.
What you can try is edit the systemd-time-wait-sync.service and add the following lines under the [unit] section.

If it doesnt help, just remove it again

I’m sorry. I’m a bit of a novice when it come to ha command line. How would I edit the systemd-time-wait-sync.service?

OK, I figured out how to access the file but it is read only. The permissions on the file are -rw-r–r–. and root is the owner. I thought I was root but it appears not. I tried sudo but that command is not found and chmod just tells me it is a read-only file system. Any idea how I become root or make the file not read only?

I was wrong. My raspberry pi is not getting an ip address.

Thank you both for your time and assistance. I found the issue was a bad ethernet cable. Once I switched it out for a different one, the raspberry pi got an ip address and now I can access it through the browser.

Good that you’ve solved it yourself :slight_smile: I’m not here every day, so sorry for the slow reply