New integration: Upnp/IGD

with the latest update to 0.80.1.beta a new integration UPNP/IGD is available, (though i have not set upnp enabled in my configuration.yaml).

on there’s no new info.

What does this integration take care of, and should we really set it? We always are warned not to, so automatic port mapping seems somewhat counter standard security measures…

never heard of a traffic sensor btw, so would know what to fill in there?


I have several ports forwarded on my router, which is also not as safe as it should be. can we use this integration to set these port forwarding? and are they maybe safer this way?

hope anyone has tested already, and would care to share experience. thx

This will actually show traffic on the router. nothing there regarding the Port forwarding.

With the new ha version 0.80 my discovery component shows the new UPNP/IGD feature. I don’t need this.

I can’t find the ignore value in this list

Does anyone know the right value to ignore this compoent?

1 Like

I also want to ignore it, tried - upnp but it doesn’t work. I keep getting message at startup thst something new is discovered and have to click dismiss.

I also got a new discovery component in this version (my d-link router).
When I look at the sensors that was automatically created all the data is 0.
How can I fix it ?

diasble upnp on your router and it won’t show up? Stopped it from doing so here.

1 Like

The value should be igd. Here’s the reference.


Disabling upnp at the router is not a good solution if you are using upnp for other things.


Using - igd in the ignore list confirmed to work for me.

1 Like

value igd worked. Thanks!

1 Like

If you really need it, you shouldn’t disable it on the router. The thing is, it is one of the bigger red flags in network security risks, enabling Upnp. So, you got to have a very good reason to enable it…

I used to believe to need it for my network devices to see each other, but since I’ve disabled it, nothing changed in my home functionality. Feels safer…
Of course, ymmv.

Having the same issue, did you manage to resolve it?

Added the upnp option and added traffic sensors. Sensors appear but data stays at 0.0

This integration made my pfSense router pretty unhappy. The router box would go completely unresponsive every 12-36 hours during the short time I had this integration enabled.

1 Like

In corporate networks sure, in home networks it breaks more things not having it than having it.

Specifically when it comes to things that require more intricate networking like Xboxes and Playstations, Apple TV’s and Plex and the like.

I think .83.x has just broken this again …

Invalid config for [discovery]: value is not allowed @ data['discovery']['ignore'][1]. Got 'igd'..

Just remove the exclusion value (-igd), for me the bandwidth sensors no longer show

Yep, that works

1 Like

i also need some reviews about this facility , is it safe to use it ?
it automatically shows in HA but all the router values are 0,
how to successfully configure it ?

- igd