New isp, new modem, slow HA

Hi there, i have changed from internet provider and i did not change anything in HA, but only some ipadresses because my old provider used, and the new one is using, so all i had was some ip reservations on my old modem, which i have kept on my new one but with the 178 in it instead of 1 and i already have restarted HA a couple times, but no changes. What happens in short when i open the app and i turn let say a light on it takes about 5 seconds for it to respond. Let’s say in a couple seconds after that i turn the blinds on it works immediately like before, so it looks like the first command takes a while. But when i close the app or i leave it and than come back i will have the same issue. I have also deleted the app, tried it on the pc which also connected by wire just like my HA machine, still same issue, does anybody know how to fix this? I have now a sagecom modem/router from ziggo and before i had a zyxel t50 from tmobile. And yes everything is up to date and it is not only zigbee but also wifi connected devices

New modem include wifi change? Maybe new wifi affect zigbee? Try change wifi channels or reduce transmit power for wifi.

Zigbee use 2.4GHz so can you use 5GHz wifi only?

My modem is in another room than my zigbee controller and my HA runs on cable. It also influences my wifi devices in HA, like my blinds and some bulbs, fan are on wifi and have all the same issue. And i have 2.4 off on my modem only 5g on and on my ap which is only used by my HA devices is have turned off 5g and only 2.4 on

I think i have fixed it by connecting it directly on the modem instead of on the unifi switch like i had before. But now i have the issue that when i am connected to the wifi 5gz from the modem i can’t use the HA app i need to be connected to the 2.4ghz of the AP. Even if i add the 5ghz ssid to the companion app. It won’t load it.