New light bulb do not get added auto to the light card on my dashboard

I have been trying to get light bulb to show up in the light card on my dashboard.
Is there limit of devices in card? why it do not show up auto as it should have.
I named the light “Oven Light” it is Cree connected light bulb.

things I tried: I removed the device and reset the device and re-added it again.
rebooted the raspberry pi 3.

I have all other Cree light bulbs show up and working.

I can turn on and off the oven light in its entity

Here is pic of my dashboard and you can see that Oven light is missing.

Here is the Oven light entity and I can turn on and off.

Did you try ‘add to lovelace’ ?


Else : in the upper right corner :


and then


It will add as new button card that I do not want…

This will add to your light card:

Entities are only added if your lovelace is still in autogen mode. Once you have taken control, you have to add yourself.

Thank you, I sorted it now.

Please consider marking my post above with the Solution tag. It will automatically place a check-mark next to the topic’s title which signals to other users that this topic is resolved. This helps other users find answers to similar questions. For more information, refer to guideline 21 in the FAQ.