New Linkind Matter RGBTW bulbs appear as white only in HA

I just got a set of these Linkind bulbs to test and it doesn’t appear they are supported properly in Home Assistant: https://www.amazon.com/dp/B0BHRZFJDN

When I query them in the Developer Tools section I see only these options:

supported_color_modes:
  - brightness
friendly_name: Smart RGBTW Bulb
supported_features: 0
color_mode: brightness
brightness: 255

Within the Google Home app these bulbs support On/Off, Brightness, White color tuning, and RGB colors. Is this something new to do with how Matter is supported in HA or is something else wrong that I missed?

2 Likes

I’ve encountered the same thing - connects as an RGBTW Bulb Matter device but no color or temp adjustments, I also unpaired and reconnected it to a HomePod Mini and then using the Matter bridge added the device to HA that way. Can control colors on the HomePod Mini but not HA - same issue.

I thought Matter was supposed to expose a common set of attributes for each supported device?

I’ve been going back and forth with Linkind support for several weeks on this now. In my case it does appear that something is getting blocked over the network, although they aren’t sure what or where. If I disable or remove my firewall and VLANs from the network, then move all devices onto a single, relatively open LAN connection, I can pair and control these bulbs just fine.

As you might guess, this isn’t a very secure way to keep the network setup, so I continue to pursue other solutions. If or when Linkind gets back to me with some better options I will update this post.

Looking at these, did they work? How do they look?

I am using a variation of these that work quite well with HA as of November 23.

https://www.amazon.com/gp/product/B0C58QVHTX

I had problems at first but that was due to my phone being on 5GHz wifi, even though the SSID has both options on my wireless access port. I have a separate SSID for IoT devices that is 2.4GHz only, switching my phone on to that network first allowed these to work.

I’ve had no trouble with these once configured in HA. I can access all of the color, brightness and temperature options in HA.

2 Likes

Thanks. 6$/bulb for WiFi vs 20 for a zigbee hue, it’s tempting. Another question, don’t care about color too much, how’s the white levels? At that price, I can use them for white mainly. I am going to order a sample to test. Lucky me, I ordered a Nanoleaf thread bulb to test, right before they added matter support, and it’s a paperweight since thread support is next to non existent yet in HA. I’ll keep it as a test bulb but I just removed multiprotocol since it was screwing with my network.

Edit. Some of the reviews state that it’s not actually local control, like it can’t be setup without the app, is that right? Would I be able to block the bulbs from accessing the CCP for example? The ai app looks like a security nightmare.

Can you share more on how you got them added to HA? I have what seems to be the same bulbs but not understanding how to get them added. Are you using a cloud integration or all local?

So it took me a second, it’s very straightforward BUt the HA and bulb needs to be on the same vlan.

I paired to the AI app and updated the bulb then I paired to HomeKit and then removed from HomeKit and it showed up to pair in HA, unpaired just fine after getting my phone on the same vlan as HA. Probably not going to buy more, it’s way more convoluted then zigbee and it’s 100% not consumer friendly yet. That said I like the bulbs and will be replacing some of my zigbee bulbs for a long term test.

Edit. Not true, I’ve been testing with the latest HA and as long as the network you are using has 2.4ghz it will pair just fine. The test bulb I got from this thread dropped off after about 8 hours though, I have a very strong wireless network so it’s not that. Matter is still a playground for now, until it can get stable and decent bulbs come out.

The white levels are superb. You wouldn’t know these can also do color if you never saw them do color. That’s the mode I use them most of the time.

I’m using only HA to configure them, I’ve not installed any other app.

1 Like

So unlike the Linkind BR30s these bulbs paired with color control enabled, thank you!

Just discovered if you want to change the power recovery defaults to “last on” (color/brightness) you can pair it using AiDot then change in the device settings, delete, and then pair with HA.

Also if you wait a few minutes while paired with AiDot the bulbs firmware will update even though it might not show a firmware update available at first…as of this post the bulb’s firmware went from 3.01.57 → 3.02.09.

EDIT 1: My mistake - I think the “Turn On” power recovery is supposed to restore color/brightness but does not at least on 3.0.1.57 from my testing. Also the power off option for recovery does not seem to work on 3.02.09.

EDIT 2: The power off option DOES work but had to fiddle with it - was not working until I turned off the lightbulb via the app then cut the power and restored. Still messing with it so not sure it will continue to work.

I’m very interested to learn about options for setting the default power on state. I’d like them to come on full bright white if the power is removed/added (typical light switch) rather than use the last setting.