New Netatmo integration

Hi Tobi,
Ill have a look into after work. Could you remind me how to debug per integration?
There is a error that pops up in server logs if that’s what you need. Cheers

Sure, no problem.

Documentation: Logger - Home Assistant
Netatmo specific line: homeassistant.components.netatmo: debug

If there is an error, please let me know.

Had a go remotely.
My log at reboot but no error.
Awhile ago I tried a reinstall of Netatmo… made no difference.
Webhook enabled/disabled made no difference.

 2021-09-22 11:51:02 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] 
2021-09-22 11:51:02 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Data class AsyncWeatherStationData added
2021-09-22 11:51:02 DEBUG (MainThread) [homeassistant.components.netatmo.sensor] Adding weather sensors []
2021-09-22 11:51:02 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] 
2021-09-22 11:51:02 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Data class AsyncCameraData added
2021-09-22 11:51:04 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Data class AsyncHomeData added
2021-09-22 11:51:04 DEBUG (MainThread) [] Adding climate schedule select entities [<Entity Netatmo House: Default>]
2021-09-22 11:51:06 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] No device data available
2021-09-22 11:51:06 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Data class AsyncHomeCoachData added
2021-09-22 11:51:07 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Data class AsyncPublicData-9b15b504-xxxxxx-xxxxxx added
2021-09-22 11:51:39 INFO (MainThread) [] Cameras are currently not supported with this authentication method
2021-09-22 11:51:45 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] 
2021-09-22 11:51:45 DEBUG (MainThread) [homeassistant.components.netatmo.data_handler] Data class AsyncHomeStatus-595df4b8xxxxxxxxxx added
2021-09-22 11:51:45 DEBUG (MainThread) [homeassistant.components.netatmo.climate] Adding climate devices []
2021-09-22 11:52:05 DEBUG (MainThread) [homeassistant.components.netatmo] Unregister Netatmo webhook (xxxxxxxx)
2021-09-22 11:52:05 INFO (MainThread) [homeassistant.components.netatmo.data_handler] Netatmo webhook unregistered
2021-09-22 11:52:06 DEBUG (MainThread) [homeassistant.components.netatmo] No webhook to be dropped for xxxxxxxxxxx
2021-09-22 11:52:39 INFO (MainThread) [] Cameras are currently not supported with this authentication method
2021-09-22 11:54:09 INFO (MainThread) [] Cameras are currently not supported with this authentication method
2021-09-22 11:56:09 INFO (MainThread) [] Cameras are currently not supported with this authentication method

Hi, today my Netatmo integration stopped working, and all Netatmo entities became unavailable in HA. A reboot solved the issue.

Good to know it might not just be me. :slight_smile:

Instead of rebooting HA you can also first try to reload the integration would should have a similar effect.

Do you have any custom components installed?

Yes a few, using Hacs.
Getting this in normal logs, not sure if related.

Logger: homeassistant
Source: components/netatmo/
First occurred: 12:19:13 (1 occurrences)
Last logged: 12:19:13

Error doing job: Task exception was never retrieved
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/netatmo/", line 198, in register_webhook
  File "/usr/local/lib/python3.9/site-packages/pyatmo/", line 351, in async_addwebhook
    resp = await self.async_post_request(WEBHOOK_URL_ADD, {"url": webhook_url})
  File "/usr/local/lib/python3.9/site-packages/pyatmo/", line 306, in async_post_request
    async with
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 1117, in __aenter__
    self._resp = await self._coro
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 619, in _request
  File "/usr/local/lib/python3.9/site-packages/aiohttp/", line 656, in __exit__
    raise asyncio.TimeoutError from None

Please deactivate the custom components and see if the issue persists.

OK. will do this when I get home… safer. :slight_smile:

A reload of the Netatmo integration doesn’t break anything, however it doesn’t bring the integration back to life sadly.

second reboot has revived things.

When a reload had been tried it doesn’t allow me to try again

Yes, I know. I haven’t investigated this yet. But thanks for the reminder.

The reload of integration might break your automation if you changed the identifier of your entities in Home Assistant. The reload will reset the names to default ‘entity_type’.netatmo_‘name_of_the_device_in_Netatmo’

Re-loading doesn’t. It is basically the same as restarting HA. Re-installing does reset your names and disabled/enabled entities when you restart HA after removing and before readding the integration.

Not getting anywhere with this sadly. Cleaned up the custom_integrations folder, disabled one by one while rebooting HA. Rebooted OS after uninstall of Netatmo, then reinstall…
Still intermittently seeing unavailable entities.
I’m in the process of disabling HA integrations now to see of any effects. I have a funny feeling it might be my ZHA integration - takes a while to load things.

Got this while reinstalling…no errors…went away after reboot.


Ill get back to you…

What does the log say when it fails to set up?

No error relating to Netatmo, just debug messages. Should I be looking else where.

Rebooted three times in a row and its been fine while ZHA and Plex is disabled. Rebooting again with just ZHA disabled.

What platform are you running HA on? Do you have a very high system load?

RaspPI 4B using HassOS and SSD.

It seemed to start either HA 2021.8 onwards or while upgrading OS from v5.13 to v6.0 onwards. (running OS 6.4 at present).

There are memory buffer issues on OS 6+. On cli occasionally get long ‘tailroom’ hash messages.
Doubt this is related though.