New NUT integration in 0.108 doesn't want to talk to my QNAP?

I’ve had NUT set up for a while as a sensor, I’ve even built a nice card for it, it has worked without a problem.

Now with 0.108 it’s moved to an integration, and that doesn’t work for the NUT service on the qnap, so what has changed in the way the integration is done?
Also I seem to be missing ups.mfr and ups.model from the features list (which I used in my card).

The config as a sensor:

  - platform: nut
    name: UPS Battery backup
    username: qnapups
    password: 123456
      - ups.status.display
      - ups.load
      - ups.realpower.nominal
      - ups.mfr
      - ups.model
      - input.voltage
      - battery.charge
      - battery.runtime

If I enter this into the integration, I just get a Failed to connect, please try again
As I only have one UPS connected to the QNAP, I haven’t set the alias.


Did you solve this problem? I have the same situation.

Yes, with the newer versions of the nut integration, I got it working, it is configured through the integrations now.

OK, thanks. I had wrong IP in QNAP configuration (two interfaces in HA, one WIFi and one eth0) . Now all seems to be ok.

1 Like

I’ve had no luck with this. Can you share what configuration details you put into NUT on Home Assistant? Also, what kind of account did you have set up on the NAS (ie., what privileges did the account need to have?)

Was there anything you had to configure on the NAS?

Here’s what I’ve got and where I get stumped …

username is always qnapups :-o
Password is always 123456

Then ‘whitelist’ the IP of the HA in the qnap.

1 Like

Perfect! I needed all 3 bits of info. The username, the password and to remember to whitelist Home Assistant as a legitimate login IP address

This has been stumping me for a while - much appreciated! :smiley:

1 Like

Hi there. Same issue in here more or less. The thing is that i have both my QNAP and HA running on same ip (e.g., of course on different ports.
(my HA 0.114.4 is in a docker (NAT Mode with poth forwarding from xx21 to Container xx23)
Whenever i try to login (localhost and port 3493 into NUT Integration on HA) it says “Failed to connect, please try again”
Tried with bot qnapups and 123456 my admin username credentials

How do i do this?

I have HA running in CS in host mode on the same NAS being my NUT master.
I successfully made the connection using:

Host: localhost
Port: 3493
Username: qnapups
Password: 123456