New Odroid N2+ with preinstalled OS won't load IP:8123

I am one of the people trying to migrate from insteon. I bought the Odroid N2+ box with Home Assist OS preinstalled. I have plugged it in as directed and am trying to load the http://homeassistant.local:8123 or IP xx.xx.xx.xx:8123 addresses. Neither will load.

I am able to ping the Odroid box on my network at the IP address successfully.

If I plug in a monitor and keyboard to the box to see what it is doing, it loads a lot of command lines very quickly and then gets to:
“Waiting for the Home Assistant CLI to be ready…
Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running? (repeats this about 20-30 times)
[warn] Home Assistant CLI not starting! Jump into emergency console…”

That’s where it ends. I have seen on some posts people said to type “login” so I tried that, but it just repeats the same output shown above.

I am stuck. If anyone can offer any assistance I would greatly appreciate it. I have combed the forums and cannot find this exact topic anywhere. Thank you.

Same here. But when I type 4357/ I get the following message:
Home Assistant observer

Still can’t figure out how to connect. A user on Discord said: paulsk — Today at 10:51 AM IMHO, if your router isn’t interfering, sounds like whatever pre-built solution you are are using is broken.

I think I’ll contact the place I bought it…

Home Assistant Bundle - Standard ODROID-N2+:

If it refuses to connect to your network, reflash the eMMC.

Warning: I’m NOT a tech geek so this was painful for me but I am persistent and so I’ve typed this up hoping it will help other Insteon exiles out there. Here’s the long version…

At the suggestion of the Hey Insteon users! page at the Home Automation blog and the linked page (Buying a device to run Home Assistant April 2022 edition) I bought the Home Assistant Bundle - Standard ODROID-N2+ 2GB/16GB from ameriDroid. Following the instructions provided, I connected the N2+ device to my network and it appeared in the router client page as “homeassistant Automatic IP 00:1E:06:43:10:AF Wired.” But when I tried connecting to it using a PC browser or the iOS HA app the connection was “refused.” When I tried both address options in a browser ([IP Address]:8123/ and homeassistant.local:8123) I got these messages: refused to connect ERR_CONNECTION_REFUSED and This site can’t be reached homeassistant.local refused to connect. When I tried to connect in the iOS HA app I got the message: NSURLErrorDomain -1004. I poked around on Discord and the HA forum and tried 4357/ at which point I got this message: Home Assistant observer | Supervisor: Connected | Supported: Supported | Healthy: Healthy. I also found a post from Brandon at ameriDroid customer support so I emailed him at [[email protected]] for a possible fix. He recommended reflashing the N2+, which for this non-techie noob was very challenging, but here’s how it’s done. 1) Unplug the power to the N2+, connect it to a USB port on your computer using a microUSB cable, set the white switch on the N2+ switch to SPI (to the left), connect a USB keyboard and an HDMI monitor to the N2+ and then plug the power back in. 2) On the monitor you’ll see Petitboot and the option to exit to shell in the screen. CAREFULLY enter the following two commands (without the quotes): “ls /dev/mmc*” and then “ums /dev/mmcblk0” [Note: you won’t get a lot of feedback on the screen as to whether anything is happening]. If you’re successful, the N2+ will now be connected to your PC and it will appear on your system as “hassos-boot.” If you’re not successful, try rebooting the N2+ (unplug and plug back in) and try the commands again. 3) Do the following (from the ameriDroid guide that came with the N2+: Download balenaEtcher. Next, download the image of the operating system from Compatible OS images — ameriDroid. Now, run balenaEtcher [the N2+ will appear as “Compute Device”] and select the “Flash from file” option and find the operating system file that was just downloaded. After a few minutes, balenaEtcher will display Flash Complete! 4) Disconnect the N2+ from the PC’s USB port, slide the white switch on the N2+ switch to eMMC (to the right), disconnect the monitor and keyboard and reboot the N2+. 5) If you’re lucky (I was!) you can once again try connecting to the N2+ using your browser or the iOS app (I did the latter, the N2+ actually appeared on the search screen). Things appear to be progressing when the screen says Preparing Home Assistant… this can take up to 20 minutes.”

This was super helpful, thank you for posting!