New pi3 installation. AIO or HASSBIAN?

Just got a new pi3, probably will move all to this new pi3 (new bigger sd, and use my oldi pi3 with AIO HASS installation to other use.

Which is the most convenient AIO or HASSBIAN?

Hello claudio,

Welcome to Home assistant.

I would counsel you to use the Hassbian installation as this is the “newest” installation method and the newest examples will assume you are on Hassbian.


1 Like

+1 for hassbian

Ok, I did install it.

Is it safe to transfer all “home assistant” folder of pi3 with AIO install on the hasspian “homeassistant” image, or better avoid?

I do have lot of custom_components

Hi claudio,

Congrats - this was done quickly.

I tried to copy all config files (yaml) in one go and it did not work out. I would counsel you to do it bit by bit and check it along the way - this turned out to be the most efficient way in my case.

Good luck!

Yes doing this and … sooo many errors … For example is mqtt installed automatically no, why I have this error?

  port: 1883
  client_id: home-assistant-2
  username: username
  password: password

17-04-21 22:25:46 ERROR (MainThread) [homeassistant.setup] Error during setup of component mqtt
Traceback (most recent call last):
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/”, line 189, in _async_setup_component
result = yield from component.async_setup(hass, processed_config)
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/mqtt/”, line 363, in async_setup
success = yield from[DATA_MQTT].async_connect()
File “/srv/homeassistant/lib/python3.4/site-packages/homeassistant/components/mqtt/”, line 473, in async_connect
None, self._mqttc.connect,, self.port, self.keepalive)
File “/usr/lib/python3.4/asyncio/”, line 388, in iter
yield self # This tells Task to wait for completion.
File “/usr/lib/python3.4/asyncio/”, line 286, in _wakeup
value = future.result()
File “/usr/lib/python3.4/asyncio/”, line 277, in result
raise self._exception
File “/usr/lib/python3.4/concurrent/futures/”, line 54, in run
result = self.fn(*self.args, **self.kwargs)
File “/home/homeassistant/.homeassistant/deps/paho/mqtt/”, line 704, in connect
return self.reconnect()
File “/home/homeassistant/.homeassistant/deps/paho/mqtt/”, line 826, in reconnect
sock = socket.create_connection((self._host, self._port), source_address=(self._bind_address, 0))
File “/usr/lib/python3.4/”, line 509, in create_connection
raise err
File “/usr/lib/python3.4/”, line 500, in create_connection
ConnectionRefusedError: [Errno 111] Connection refused

Hi Claudio,

MQTT is not installed automatically - did you run the scripts after having installed Hassbian?

These are scripts which will allow you to install:
1/ Samba, 2/ Mosquitto MQTT, 3/ Open Z-wave and 4/ Libcec for HDMI-CEC support

I recall I had big issues as well with MQTT - I finally uninstalled it and reinstalled it following the videos on BRUH automation.

Quite frustrating, but finally worked out

Good luck

I thought mqtt was embedded.

Anyway now I installed mksquitto, but still have issues

God evening Claudio,

As said before I also went from AIO to hassbian and had several issues ,(including with mqtt)

Please describe your issues and I will try to remember the possible solutions