New Sonoff RF Bridge Board - Need Flashing Help

You most likely have enabled dump: all. That’s not meant to be kept enabled. Try enabling less noisy damps until you find your device and then disable dumping completely

Hello, maybe anybody can help me to control my novy hood with sonoff V2 2.2.

I have used the direct hardware hack und added ESPHome.

It looks like, that I have do all right, because I can see button pressed on my Novy remote control in the log.

Here are the results in the mode:

  pin: GPIO04
  dump: raw

[10:37:45][D][remote.raw:041]: Received Raw: 365, -395, 722, -750, 360, -400, 717, -755, 362, -401, 716, -755, 364, -395, 715, -757, 362, -398, 715, -756, 361, -755, 364, -751, 364, -404, 708, -755, 364, -398, 717, -398, 719, -398, 714, -758, 362
[10:37:45][D][remote.raw:041]: Received Raw: 364, -394, 716, -755, 365, -395, 717, -755, 362, -400, 715, -756, 363, -398, 714, -755, 365, -396, 716, -755, 364, -753, 362, -752, 363, -397, 717, -756, 366, -393, 717, -400, 714, -403, 718, -754, 364
[10:37:45][D][remote.raw:041]: Received Raw: 364, -396, 716, -758, 362, -397, 715, -757, 362, -398, 717, -755, 362, -398, 714, -757, 365, -396, 722, -751, 365, -753, 364, -750, 365, -396, 718, -755, 362, -398, 717, -400, 712, -402, 718, -754, 366

That looks like the codes, that other libs also using:

I pressed Light toggle Button.

In this mode:

  pin: GPIO04
  dump: rc_switch

[10:43:47][D][remote.rc_switch:261]: Received RCSwitch Raw: protocol=6 data=‘010101010111010001’
[10:43:47][D][remote.rc_switch:261]: Received RCSwitch Raw: protocol=6 data=‘010101010111010’

BUT: I can not send the right code.

I have tried it with

  - platform: template
    name: Licht Toggle
      - remote_transmitter.transmit_rc_switch_raw:
          code: '1011001011001011001011001011001001001011001011011011001'
            times: 10
            wait_time: 0s

Also with

  - platform: template
    name: Licht Toggle
      - remote_transmitter.transmit_raw:
          code: [365, -395, 722, -750, 360, -400, 717, -755, 362, -401, 716, -755, 364, -395, 715, -757, 362, -398, 715, -756, 361, -755, 364, -751, 364, -404, 708, -755, 364, -398, 717, -398, 719, -398, 714, -758, 362]
            times: 10
            wait_time: 0s

I have played yesterday a lot with the codes and the repeat values. But the result was the same. I can not control my novy hood.

Thank you Bjoern

I have used a lot of time to read this thread, but cannot seem to understand or find the answer that I am looking for. :slight_smile:

So far, I have gotten a hold of the latest Sonoff RF 433 Bridge R2 (with the V2.2 printboard i think)

I have succesfully flashed Tasmota on it, paired it with my wifi, and setup MQTT which seems to be able to send commands to the bridge.

To be able to send RF commands to my blinds, do I need to do anything else ? ( I have not cut the print , only flashed with Tasmota )

The console in Tasmota is giving me this, when i press the buttons on the remote:

// Blinds up button:
11:47:16.040 MQT: tele/rf-bridge/RESULT = {"Time":"2023-02-09T11:47:16","RfReceived":{"Sync":10676,"Low":702,"High":1418,"Data":"48E257","RfKey":"None"}}

// Binds down button:
11:47:09.480 MQT: tele/rf-bridge/RESULT = {"Time":"2023-02-09T11:47:09","RfReceived":{"Sync":10602,"Low":702,"High":1418,"Data":"48E257","RfKey":"None"}}

With RFraw output

// Blinds up button:
11:50:16.498 MQT: tele/rf-bridge/RESULT = {"Time":"2023-02-09T11:50:16","RfRaw":{"Data":"AAA429CC02C0058848E25755"}}

// Binds down button:
11:50:20.023 MQT: tele/rf-bridge/RESULT = {"Time":"2023-02-09T11:50:20","RfRaw":{"Data":"AAA429C802C0058848E25755"}}

It looks to me, as if the payload for “up” and “down” is identical when looking at the “none raw” version. But the remote works fine using the buttons.

I tried to send the command with the payload from the console, but nothing happends.

What am I missing here?

Do I need to send more than just the “Data” field for this to work?
Or do I need to do some cutting to the board itself? flashing the RF chip (which seems not possible as this is the new version or…) ?

Bonus info:
I also tried to set it into “learning mode” by running the command: RfKey1 2
The device beeps one time and starts to listen. But it does not end the learning mode.

Don’t use Sonoff Bridge(25) as template… you need to use Sonoff Bridge (0) i.e. with this template… {"NAME":"Sonoff Bridge","GPIO":[32,0,0,0,1152,1120,0,0,0,320,0,0,0,0],"FLAG":0,"BASE":25}

1 Like

@schmurtz thank you for the direct hack instructions.

I followed them exactly and didn’t run into any issues until the end. All I get in homeassistant is a connection refused errors.
RF Link is set in the config.yaml as:

port: 1234

Is the port number arbitrary?

Also can someone clarify, following the direct hack and Flash_SonoffRF.bat, is it possible to switch to tasmota/esphome and still learn RF commands from remotes?

I just wanted to say a thank you to everyone involved in this and the other threads about the v2.2 RF Bridge. I’ve been a HA user for about 7 or 8 months and wanted to see if I could get my Byron BY home doorbell hooked up to HA. I bought the RF Bridge (v2.2) and my first ever soldering iron, serial programmer etc.

Managed the direct hack on about my third attempt (struggled with the solder connection to the little 6 pin chip), flashed all sorts of firmware (Tasmota, custom RFLink and today ESPHome) and have at last made progress. Using the raw logging from ESPHome (I love how easy the HA integration is for uploading new firmware) I managed to find my doorbell (which wasn’t being picked up - or at least easily for me to see - by tasmota or RFLink) and have added a sensor for it. The bridge is now hidden away and I’m getting mobile phone notifications from the doorbell.

Thank you.

I’ve been following this threat for a while now and I noticed that you seem to be using the same Gumax shading as I am.

With the older version (R1) it should work, but so far I have not found a solution for the version R2, with which firmware this must be flashed to control the Gumax motors.
Have you managed in the meantime to control the shading with the Sonoff RF Bridge R2?

If so, I would be very grateful for tips!

Kind regards,

I’ve been trying to flash my RF Bridge 2.2 for days now but I just can’t get a connection with my FTDI adapter.

RX and TX are swapped and when I plug in the FTDI adapter with the RF Bridge connected, I hold the button down for 5 seconds. I also tried to hold it down the whole time but neither with Tasmotizer nor with the ESPHome Web Flasher I get a connection. 3,3V are also selected on the FTDI adapter.

Should anything light up on the RF Bridge when the connection is successful?
I have disconnected all lines as in the instructions. Can also upload photos again.

Anybody have an idea what the problem is?

I solve the Problem. It was the soldering I did not do correctly the first tim :slight_smile:


I am also from Germany and I am trying to control my projector screen which has a 433Mhz remote control.

I have also first had many lines and then my YAML file like yours adapted again and again.

Currently I have managed to break down the values to the following results:


Received RCSwitch Raw: protocol=1 data=‘101000110011011100000110110010100000000100000000101100010011’


Received RCSwitch Raw: protocol=1 data=‘1010001100110111000001101101000010000000100001101001011’


Received RCSwitch Raw: protocol=1 data=‘1010001100110111000001101101000010000001000110001101011’

How do I proceed now? What do I have to set now to be able to send the stuff to the screen as well? Thanks in advance and I hope you got your control working in the meantime.

I have R2 v2.2 and need a stable integration to HomeAssistant but don’t like the Sonoff closed software.
I’m not good at soldering so my plan is only flash ESPhome / Tasmota without the hardware hack (soldering CPU pins & trace cuts).
Now the question is:
If all my devices use only ev1527 protocol (which Sonoff original software should support), can the device after re-flash somehow use the onboard OB38R08A1 decoder in ESPhome / Tasmota to decode ev1527 remote codes?

OK, I flashed with Tasmota-sensors firmware and the decoder is working OK for sending the short codes to HA.

Hi there,

First things first … thanks for those that made reading RF with the V2.2 possible.
I have followed these steps:

  1. Direct hack as indicated.
  2. Flashed the board with Tasmota (aka 13.1.0 with the sensors firmware).
  3. Configured the template as indicated with the GPIO4 and GPO5.

Then I open tasmota console log and I success with showing the RF commands my devices are sending.

But, now the question/problem if anyone has faced it. Before I integrated into HomeAssistant, I’m trying to send RF commands from the sonoff tasmota console using the following commands:

This is what one of my blinds is sending when pressed (printed in the tasmota log)

RSL: RESULT = {“Time”:“2023-09-21T07:47:06”,“RfReceived”:{“Data”:“0x1337C8”,“Bits”:23,“Protocol”:31,“Pulse”:405}}

Now, I wanted to “send” that exactly command from the Sonoff to see if the blinds goes up as follow:

RFsend {“Data”:“0x1337C8”,“Bits”:23,“Protocol”:31,“Pulse”:405}
RSL: RESULT = {“RfSend”:“Done”}

But nothing happends, not sure if I’m doing something wrong or is the tasmota the issue. Has anyone face the same issue? How can I troubleshoot the root cause?

Thanks for your support.

Not sure if this might be related to the encoding of the rollers. Got the information that those rollers are actually using codes based on “KeeLoq”. So, not sure if the sonoff rf bridge will work? Anyone has tested something similar?

Finally someone doing exactly as I am. I’ve done all the steps you outline, 1-3, but I can’t receive any codes!

Did you put this in the config other menu, “{“NAME”:“Sonoff Bridge”,“GPIO”:[32,0,0,0,1152,1120,0,0,0,320,0,0,0,0],“FLAG”:0,“BASE”:25}”? Or did you just use the generic template and out in the RFsend and RFrecv or how exactly did you do? I’m losing my mind over here!

Hi @artpax,

I have tried both thing, using the default template and configure the GPIO4 and GPIO5 and using the custom template with the indicated configuration (as far as I know … it’s basically the same) … but had the same results.

I do see codes from my devices and even my neighbour … but I can’t make it to send RF signals, it says … “Done” … but nothing happends. Not sure if it’s related to “KeeLoq” or what … but I’m a bit lost. I read somewhere … that KeeLoq has been already “hacked” so there are ways to do something … but not sure how “easy” is.

PS: Before applying the hack … I didn’t see any of my devices signals … but after, all they popped up in the console.

Anyone want to check my Sonof RF Bridge v2.2 guide for Tasmota
Flashing, Direct Hack Mod and linking to Home Assistant.


Very nice, although I found ESPhome to much faster than Tasmota in detecting rf codes from my remotes (I use them as scene triggers)

Hello everyone , i own an rf bridge and i can’t learn any rf remote on it . i want to pair some remotes from gates and doors . Does anyone have any clue ?

So, I have a Sonoff v1 board, and try as I might I couldn’t get the modification to stick. My soldering talents are limited.

I’m only after being able to control my Falmec hood which rflink supports, do we know of anywhere that would sell a pre-modified Sonoff bridge. Thanks, all.

i did the same and now it is not receiving any rf waves anymore