New to Docker: HA not discovering items

I am new and switching from running HA on Virtual Box to running in a Windows 11 docker desktop docker container. My docker HA install went well, but now docker HA doesn’t report finding automatically any devices like my VirtualBox version did last year. What is needed, so docker HA auto finds my existing items?

I did add a “discovery:” to config file it is still not auto discovering anything.

Here is my docker-compose.yml

version: "3.9"
    container_name: ha
      - 'C:\homeassistant:/config'
      - TZ=America/Chicago # get your Time Zone from -
#    network_mode: host
      - '8123:8123'
    restart: always
    # you can comment all the rows below if you don't need health check
      test: 'curl -m 90 -sLf http://localhost:8123 || date >> /config/healthcheck' #| pkill -9 python3'
      interval: 90s
      timeout: 60s
      retries: 2

my configuration.yaml

# Loads default set of integrations. Do not remove.

# Load frontend themes from the themes folder
  themes: !include_dir_merge_named themes

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

Why did you outcomment net=host? The doc is clear this should be used, or?

1 Like

I forgot to mention I am using docker in windows 11. I will included that in my original post

I deleted my image and container and tried adding that line and with/without the ports lines, and this appears to not work in windows 11.

windows docker does not support host-mode :thinking:

1 Like

It is a long time ago that I tried this but … can you set it to priviliged?
All in all… on windows you will find other issues so recommend to try something else.

1 Like

To not run on Windows, but on Linux, and to follow the install docs :wink:

1 Like