New to Home Assistant....lost already :-)

Last week I installed what I thought was hasbian from a github install script. Everything seem to go fine and I can log into home assistant from the Raspberry local ip at port 8123. A welcome page comes up and provides a link to “configuring home assistant”. That page explains installing hass-io add-ons but I don’t think I have hass-is. Just looking for some tutorials on where to go next. Kinda lost at this point.

This is the install page I used:

edit-apparently my link was frowned upon. No bad intentions, just trying to provide as much info as possible. Link deleted.

Thanks in advance,
Dan

hassbian is a install of Home Assistant (HA) ontop of a rasbian image.

Hass.io is an image that uses docker containers to provide a HA instance and and also provide add-ons for certain functions.

They both run home assistant but do it via different install methods. The docs are not super clear and this distinction often confuses people. A revision to the docs is in the works apparently.

If you got the welcome page via your local IP:8123 you have HA installed correctly and its ready to go.

Next step is learning to edit the configuration files and integrating your home automation hardware.

I prefer to edit my files in a text editor and access the files from a samba share.

This forum has a great community of people that will help you while you are getting started. Just post up when you have a question and someone will answer it.

If you’re confused already, I don’t mean that in a rude way, just go straight for hass.io as it will make your life so much easier, especially in the early days.

Installation if you are using the generally recommended ethernet rather than wifi is literally just flash the provided image to an sd card, insert it, power up it up and wait. Most of the worthwhile extras are a one click installation from a menu rather thsn having to get into linux and do it manually.

This is the page you want to follow…

This vid will explain most of what you need to know…

1 Like

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

But that is exactly what Home Assistant is?

Which ones?

The thing with hass.io and it’s add ons is someone else has done all the hard work making everything work together but equally making them completely independent. If you really want to go DIY you want to be looking at a docker install rather than what you have anyway for the package independency you get with hass.io.

Most of what you’d install ‘manually’ are prepackaged in the same way hass.io add ons are just with more work and likely headaches and all the HA components are again just prepackaged apps so you’re not really achieving what you want anyway.

Some thoughts:

  1. Can’t help you here. Beyond my knowledge. With Hass.io the OS is pretty locked down, but it would seem network connectivity configuration would be similar to other OS installations, as long as it doesn’t require installing additional OS-level software.
  2. Yes, I have auth keys and SSH to my Pi at both the OS level and at the HA level (the docker running on the OS), but I rarely need to, as you don’t typically do that to install anything.


  1. Can’t help you here. Beyond my knowledge.
  2. If you have a spare memory card for your Pi maybe you can spin up a Hass.io image and try copying over key components of your current setup as a way to jump start a trial run. Personally, I prefer Hass.io so I don’t have to mess with OS maintenance and manually installing components for future add-ons, as that’s all part of the package, but you may need more manual sophistication at the OS level?
  3. I have a 2gig gc2 with alarm.com. Frankly, there’s not much crossover I’ve been able to get working so far (other than arm/disarm). I can add zwave devices to my gc2, but I opted for an Aeotec zwave stick running on my Pi so I had local control. My other 2gig connected sensors are not compatible with zwave, and are not surfaced in a way I’ve been able to access via the 2gig or alarm.com. I’m still looking for opportunities to link the two so my door and window sensors and motion sensors can be part of the party. One option I’ve considered investigating further (based on other posts I’ve browsed) is to get a radio receiver that could monitor the frequency of the 2gig sensors and relay that to HA. You may have different sensors or perhaps the gc3 is more open? I’d be interested in hearing your experience as you progress. In the mean time, I’m using motion sensors in my ecobee, and other options to monitor presence, etc.

Hope there’s something helpful/useful for you.

Thank you very much for your response. I play when I get a chance. Today, I had an hour and it dawned on me that the fabric-home assistant install I did is no where to be found other than the github site I installed it from. I have no idea what fabric is. Anyway, after all the earlier posts, I convinced myself to get another sd card and install hass-io and see what happens.

I really love my gc3. I did purchase Aeotec z-wave stick also…willing to experiment and love to learn…

Since you sound like a network/computer guy like myself, I’d recommend using the following method:

This creates a virtual environment (similar to docker, but not docker) for Home Assistant on your Raspberry Pi. It gives you full access to the operating system (unlike hass.io), and allows you the flexibility to do anything you want with other apps on the Raspberry Pi, as long as there are no port conflicts. You’ll spend a little more CLI time getting each add-on to run, but you’ll have full control over everything.

As far as answers to your questions:

  1. I’m not running hass.io, so I can’t speak to if it is capable/allows this. If the native Raspbian OS can support VLANs (which I’ve never tried), then it is possible to configure the OS and run Home Assistant using the method I posted above.

  2. Again, I’m not sure about hass.io, but using the method I posted above, yes.

  3. Yes, regardless of hass.io or the method I posted above.

  4. You would have to wipe the card with hass.io, but not with the method I posted above.

  5. I can’t speak to this one, as I don’t use those devices.

Is there some reason you wouldn’t put the VLAN tag on the port rather than the device?

yeah. https://home-assistant.io/addons/ssh/

Do you mean SNMP? SMTP is mail. You don’t monitor network health by mailing the devices…

always keep extra SD cards laying around when working with PIs. They can fail at any time.

Sorry, I don’t know what that is or how it is implemented in your current configuration.

You’d have to know the history of Home Assistant for it to make sense. Originally, HA was just installed on anything running Python.

Then components started being used, one of which was Z-Wave. So people would install HA, then install OpenZWave as a separate package on the same machine. The two had nothing to do with each other, other than both being able to talk ZWave.

All of a sudden, things started breaking and the developers were having to fix them. This was caused by people updating their Raspberry Pi/Linux to a later version, which updated components that HA used, which broke things.

This, the Virtual Environment was introduced. That’s where the Fabric script came in. It install the VE, installed HA in the VE, along with thing like OpenZWave, etc.

The problem is, that all of it was based on a particular version of Python. When Python support for that version was announced as end-of-life, HA re-wrote come of the code to work with later versions. Part of that is what “broke” the Fabric script.

Meanwhile, Hass.io had been introduced, along with Hassbian, along with the already existing manual installations. So now you have options on how you want to install.

The biggest reason for “killing off” the Fabric script installation was the fact that things like OpenZWave is no longer needed, unless you just want it. ZWave support was introduced natively in version 0.45 (I believe). So now there’s not really a “need” for the script. Plus, updating the script and running it under Raspbian Stretch still takes 2-3 times as long to install compared to the method I posted above. And using the method I posted above, you only install the parts that you want/need, so you don’t have your RPi loaded down running software that you won’t use.

Trust me, I’ve hacked the script and installed it on Raspbian Stretch more than once. At the end of the day, when I physically damaged my SD card, I ended up reloading it with Raspbian Stretch and using the method above to install. I was done in about 45 minutes, compared to the 1-2 hours for the script. And with the script, OpenZWave and MQTT still don’t install properly, so you have to manually uninstall them and reinstall them anyway.

You just made my mind up. Is there a way to uninstall the fabric script? As I looked through the install script, several things failed.

By default that is the case.

You can, however, with any managed/smart switch, set a particular port to have a different ‘default VLAN’ or ‘PVID’ as some switches call it. This would allow your device to connect to that port and be on the VLAN of your choosing, without having to tag the traffic coming from the device. This is a much easier option than forcing tags (especially if you happen to be running some piece of equipment that does not allow for VLAN tagging)

There’s not really a way to uninstall the scripts, but you can delete the virtual environment it created. Then you just remove the fabric* directory under your ~\ folder. Once that’s done, you may need to check your /etc/systems/system folder for any items created during the script install (home-assistant.service, mosquito.service, and OpenZWave.serivce) and remove those. That’s all you need to do before reinstalling using the directions I posted above.

That is correct. The “virtual environment” install link I posted above and the AIO install utilize the same virtual environment setup.

Some of what you’re probably reading deals with the AIO, which does have a mid-stream change in which installs prior to a particular date were setup with one username, whereas any AIO install after that date used a different username.

You should be able to use the AIO instructions for most components, but if they reference activating the virtual environment, use the steps in the link I posted above to activate it. Once you’re in the virtual environment, you can then follow their steps the rest of the way.

Also, as far as ZWave is concerned, I’ve found that the best thing you can do it to make your ZWave stick have a consistent name, such as /dev/zwave. If you need me to dig up that article, I can do that when I’m back at a normal computer.

You have been such a great help…I really appreciate it. I don not have any issues with the name of my wave stick staying consistent. My current issue is my linear gd00z garage door opener needing the dev version of OpenZWave. I have found a very confusing set of examples that seem to work. After that, the adc t2000 thermostats…but I haven’t found a single help for that one. I don’t think my 2gig gocontrol3 is being properly recognized as a secondary controller either. Right now I just hope I don’t blow things up with the OpenZWave update.

Keep in mind that if you use OpenZWave to program your devices (names, etc), shut down Home Assistant first. Once HA is shut down, open the OpenZWave Control Panel and do what you need to do. Then shut down OpenZWave and fire up Home Assistant. This way, all your changes to the OpenZWave config file will be saved and can be referenced by both software packages.

You don’t need it to use OZWCP if you are installing the OZW service. Just know that HA has a ZWave section in it, so it you are on a later version, you don’t have to have OZW installed. You can still modify your zwave.cfg file and insert your unsupported devices manually.”, as long as HA is shut down. When you restart it, HA will pick them up if it can interpret what type of device you have.

That is really all you should have to do. Have done it several times myself with no issues.

Pretty much, assuming you’re running as homeassistant and the virtual environment is /srv/homeassistant:

  sudo su -s /bin/bash homeassistant
  source /srv/homeassistant/bin/activate
  pip3 install --upgrade homeassistant

The old AIO (Fabric) install used /srv/homeassistant/homeassistant_venv, so it would be:

  sudo su -s /bin/bash homeassistant
  source /srv/homeassistant/homeassistant_venv/bin/activate
  pip3 install --upgrade homeassistant

If you used the old AIO installer, just check that you’re using Python 3.5.3 or later. You can check with:

  sudo su -s /bin/bash homeassistant
  source /srv/homeassistant/homeassistant_venv/bin/activate
  python -V
1 Like