New to Home Assistant. Trying to add Xiaomi Vacuum

I have Home Assistant up and running on a Pi3 using recommended image file. The main issue I have is knowing what to do next. I want to integrate with my ISY994i and with my Roborock S50 vacuum (I have the 32 digit token already). But I am totally lost on how to add the add-ons for the ISY or the Roborock. I can find a Github listing for both devices for Home Assistant, but am lost what to do next. Any help is appreciated!

BTW, I do have configurator add-on installed so that I can edit /config/configuration.yaml.

I do not really know what the ISY994i is for, however the Roborock S5(5) is easy to connect to Home Assistant if you already have the token assuming you do not want to root your device.

In your configuration.yaml file add the following:

  - platform: xiaomi_miio
    token: TOKEN_HERE

If you do not know the IP address of your device you will need to look for it first in your router (or other means of getting IP addresses from your network). While looking for the IP I would also suggest you to give it a static IP in your router so that it won’t change IP for whatever reason.

If you do not have it connected to your home network yet, you will need to do this first. To do this you will have to download the Mi Home app and pair your device to your Mi account. (if you are on Android you could replace the Mi Home app with Flolevac after setting it up). The robot will restart automatically after being added to the app and connect to your home network. Repeat the previous step with the static IP if you have just finished setting this up. (I assume you have it already connected to your home network, that is why this step is shown last).

After adding the vacuum to your config, restart Home Assistant and you will have new vacuum entities and vacuum services that you can use on your Xiaomi Roborock.
If you are lazy, or want a quick way to set it up in lovelace after adding the Roborock to your setup you can check out this great custom card:

1 Like

I thought there had to be more than just adding those lines to the configuration.yaml, since I never added any code. But I did as you said and sure enough, it found my S50 and talks to it just great!! Thank you sir!!

1 Like