New to Zigbee; ZHA with Hue lights seems flaky

I’m running HA on a Pi 4, trying to keep my system lean and simple. I’ve only been at this for a couple of months so I’m still in the “oo, shiny new connectable thing, let’s try it out” phase. I have Hue lights, a Hue bridge, some Shellys, and some cool new Athom ESPHome smart plugs as well as the usual assortment of existing house stuff (Sonos, NAS, mobile phones, Bosch appliances on Home Connect) and two Tuya devices which are using Tuya Cloud (unfortunately I upgraded their firmware before realising that I should flash with Tasmota).

I got a Conbee II and used it to set up a few Zigbee devices, starting with some Aqara temperature sensors; this seemed to work well and be easy. I then disconnected my Hue lights from their bridge and added them as Zigbee devices to try to get everything on the same network and help meshing for the sensor devices. Everything worked well for the first day. It’s been a couple of days, and I now see several of the Hue lights being unable to be switched on/off even though they are still shown in the ZHA topology map. The Pi is no farther than 5 meters away from the farthest Hue light.

I am wondering if ZHA is flaky and I should try deConz instead, or (gulp) move to MQTT? Any thoughts on pluses/minuses here, please?

ZHA isn’t flaky, it’s more likely you don’t have stable coverage of your Zigbee signals. If you use devices that are considered Zigbee routers, they relay signals back to your host system. By placing these devices at reasonable distances from each other, you insure solid signal coverage.

Thanks. I’m struggling to understand how the lights can become unavailable when they have not moved, and the Zigbee receiver is much closer to the lights (which are routers) than the Hue bridge was. In one case, the light is 5 meters away from the Conbee stick in an open hallway with nothing to get in the way, and because it is a light bulb, it is constantly powered. The lights were never unavailable when I used the Hue bridge.

The HA logs do indicate that something is going wrong when trying to reach the devices:

The ZHA logs also similarly indicate some comms failures:

Device 0xfdd5 (00:17:88:01:08:67:f0:c8) joined the network
[0xfdd5:zdo] ZDO request ZDOCmd.Device_annce: [0xFDD5, 00:17:88:01:08:67:f0:c8, 128]
[0xfdd5:zdo] ZDO request ZDOCmd.NWK_addr_req: [00:21:2e:ff:ff:08:10:79, 0, 0]
[0xfdd5] Delivery error for seq # 0x26, on endpoint id 0 cluster 0x8000: message send failure
[0xfdd5:zdo] ZDO request ZDOCmd.NWK_addr_req: [00:21:2e:ff:ff:08:10:79, 0, 0]
[0xfdd5] Delivery error for seq # 0x3c, on endpoint id 0 cluster 0x8000: message send failure
[0xfdd5:zdo] ZDO request ZDOCmd.NWK_addr_req: [00:21:2e:ff:ff:08:10:79, 0, 0]
[0xfdd5] Delivery error for seq # 0x3d, on endpoint id 0 cluster 0x8000: message send failure

Given the physical topology, I just can’t understand why there are comms failures occurring here.

I’m going to hazard a guess and say those Hue lights may be using non-standard Zigbee communication. Otherwise, be patient, and I can guarantee you some Hue bulb users should comment.

You may want to edit your subject to include “Hue lights” in the text.

1 Like

Make sure your conbee is not plugged straight into the computer, it should be plugged into an extension cable and be about 1m away from the computer.

This is a bit ‘out there’, however I have seen some of my devices ‘go back’ to there originally linked hubs after moving them to new hub, this after them working for awhile on new hub. And after this occurs, they still ‘show’ on the new hub, but do not respond. I am as yet not able to quantify this behavior. That said making sure you do a ‘remove’ on the old hub with the device ‘online’ with that hub, and then before adding the device to the new hub, do one or more factory default resets of the device if possible. And make sure the old hub is not in ‘add device’ mode when you are trying to add to new hub. This is difficult with Hue devices as they often have a different remove and return to factory defaults. But I do remember seeing that they have some return to factory defaults instructions at their web site.

1 Like

There are 5 ways to reset hue listed here Philips 433714 control via MQTT | Zigbee2MQTT

I have this working now. I tried lots of things:

  • Yes, my Conbee was plugged into a 1 m USB extension already.

  • I booted up a spare Pi and played with deCONZ/Phoscon. During this process I updated the Conbee II firmware, which I think was key to this whole thing. I’ve got to figure out how I can keep on top of firmware updates while the Conbee is in the HA Pi box.

  • Reset all Hue bulbs. This was a bit laborious, and I ended up using Touchlink and a very loooong set of Ethernet and power cords. But it worked!

  • Re-paired all the sensors, with good results.

Now I don’t see any comms failures, but I do need to re-pair one sensor that is now across the house from the paired router, with other better router choices located closer to it. Working on that.

Thanks for the input and help.

1 Like

Also always make sure that all your Zigbee router devices including your Philips Hue bulbs always have permanent mains-power as all Zigbee routers should always be online in a Zigbee network by design.

for more general tips see:


@arrows now that you’ve had your network up for some time, I’m curious what your experience has been so far. Is it still working?

I recently added a SkyConnect to my system and transferred all 55 of my Hue bulbs from Hue Bridge to ZHA…while they’re all “working” I regularly find certain lights to be unresponsive, despite having decent RSSI (<-70) and showing no issues in the system. I’ve added 4 non-Hue routers to the mix (3 dedicated repeaters), but I’m still finding certain lights just not working when I need them. I’ve repaired these devices more times than I would ever wish on anyone and I’ve done all of the obvious things to optimize your system (USB extension, USB 2.0 powered HUB, moved my actual HA system to the exact spot where my Hue Hub worked flawlessly on my middle floor, added 3 Aeotec Repeaters, and I even bought some of the Sonoff dongles that can be flashed to routers with -20db antennas, but I couldn’t get them to take the firmware… It’s getting to the point where I’m going to be forced to switch back to the Hue Bridge since I’m not the only person that lives here…

I really wish Zigbee had a “heal” concept like Zwave since I would hope that each adjustment to the system would allow it to optimize over time to determine which devices provide the best path to the controller. Maybe I’m missing something or Hue Bulbs are just not good routers outside of the Hue ecosystem? Any other advice you have from someone else new to Zigbee, please share.

It’s been a while - my system has evolved significantly. I got pretty tired of the flakiness of the Hue connections. I stopped using the Hue bridge and instead added a few Zigbee signal repeaters. This seemed to make a big positive difference; since doing this my Zigbee system seems pretty stable.

1 Like