New Tuya integration dont sync to HA



I cant see these 2 devices in HA

What sort of devices are they?

lights and water leak sensor

only light is important for now

I have 11 Tuya devices that all worked fine in HA prior to the 2021.10.x updates.
I have always used SmartLife as the Tuya only app and that still works fine.

In HA after (I thought!) successfully migrating to Tuya IoT 2.0 and updating to HA Core 2010.10.0/1/2 only 9 devices now show up in HA out of the 11
The two that don’t are a generic PIR unit and a Quinetic dimmer/switch receiver. As I say both worked fine beforehand.

Next issue. Out of the 9 that do show up, only 5 of them (smart switches and sockets) actually have any tangible connectivity; they do not switch on or off and they don’t show any status when I use SmartLife to switch them.

They show up as light.xxxxx domains which is a bit curious as they are switch/relay type devices. That said, they have always showed up as light domain device in HA, even though Tuya IoT platform says they are ERC309 switches and the product category dj, which I’m sure is a supported category according to the HA table I found.