New Tuya Integration - My IP doesn't have access to API

Anyone else received this error when trying to setup the Tuya integration? I don’t have any IP allowlist settings enabled. My devices are registered to the cloud project and I can see them listed.


Yes, I’ve had the same problem today, have you fixed it?

Did you use the correct ID & secret?
This can be found in Cloud-> development-> Authorisation.

Yes. This is resolved for me now.

You have to uncheck this option, or you have to add your ip if you want to leave it on


That wasn’t the issue.

Check you didn’t accidentally use the Chinese data centre when you signed up. I set up the integration for my brother, and had a headache for half an hour because the integration kept complaining about the data centre, and I had to figure out how to move the app to the correct data centre.

Nope, it was similar though. I think the account was from before there was a UK region. Tbh I can’t remember how I fixed it now.

Hello Evryone,

I don’t know if it’s still an issue, but you have to click on"configure" and the IP adress causing you the problem

That wasn’t my issue.

Do not use Tuya IoT Platform username & password in HA, but instead Cloud Authorization Access ID / Client ID + Access Secret from Tuya IoT Platform (Cloud - Development - Your project - Authorization). And then normal Tuya credentials for “Account” fields in HA.

I had also 1114 Login error, while I tried using my Tuya IoT credentials in integration wizard in HA.

1 Like

Thanks man, it was stated wrong in the manual… glad i have found the answer. Hopefully they will correct the error.