New user: HA won't discover Gosund SW5 wall switches

Hi Guys, I’m brand new here and am having some difficulties getting HA Green to see my Gosund wall switches. I bought the switches at the same time as HA. Now I see in HA the Gosund switches are not listed under “Brand Name” in the add device section.
I’m running a TP Link (Archer 1800) router and have turned off the 5G portion of the router and some of units from my home entertainment system have been discovered, but no light swtches. I’ve restarted my router and HA Green. I’ve tried holding down the switch for approx 10 seconds to get the red light flashing. Still no results.

I searched for Gosund SW5 and found another member was using them and they are failing. I just want to know how to get them working.

Thanks in advance for any help,


OK, I’ve done some more work and HA has found one of my switches and it is a Tuya brand! Great. Now I try to configure it and I get a QR code that wants me to download the Tuya app, which I did. Now I’m stuck again. I’ve got a user code, but can’t get past the QR screen…
What now?