New version of the plant integration

Did you figure out what the “dli” is tracking? Could it be Daily Light Integral? Get Perfect Plant Lighting (Plant DLI Chart & Calculator)

Yes it is the day light, I just changed the low value to 0 in the integration bc it was not really reading the correct values

I have configured flower-card to show accumulated light - dli, but it shows always zero?

type: custom:flower-card
entity: plant.miflora_1_2
  - moisture
  - illuminance
  - temperature
  - humidity
  - conductivity
  - dli
battery_sensor: sensor.plant_sensor_b161_battery

Can’t we get this into home assistant? this should be the default?


I’ve added the lovelace card and updated everything. The card appears with no stats, only image of plant, if I try to add manually in reports this.

Any idea to solve?

Hi all. Just a head-up, this integration currently is not working well with the latest version of HASS 2023.7. Please hold off the upgrade until it’s fixed. To track the issue see here:

I have installed the following:
GitHub - Olen/lovelace-flower-card at new_plant
GitHub - thomasloven/lovelace-card-tools: :small_blue_diamond:A collection of tools for other lovelace plugins to use
GitHub - Olen/homeassistant-plant: Alternative Plant component of home assistant

But if I try:

type: custom:flower-card
entity: plant.orchidee
- brigthness
- moisture

I got only:

But I have the datas:

problem: conductivity low
  moisture: sensor.plant_sensor_908d_moisture
  battery: sensor.plant_sensor_908d_battery
  temperature: sensor.plant_sensor_908d_temperature
  conductivity: sensor.plant_sensor_908d_conductivity
  brightness: sensor.plant_sensor_908d_illuminance
  temperature: °C
  conductivity: µS/cm
  brightness: lx
  moisture: '%'
moisture: 23
battery: null
temperature: 26
conductivity: 40
brightness: 101
max_brightness: 4066
friendly_name: Orchidee

What I make wrong?

And the secound question, how can I get the Picture instead of the icon?

This is fixed now.

Please update to the latest version of both he openplantbook-integration and the plant-integration.

There is (was) a typo in the config in the README.
Try without the “show_bars” part of the config.
If that works, try to replace “brightness” with “illumination” wich should be correct.

This code doesn’t work either:

type: custom:flower-card
entity: plant.orchidee

You need to provide some more info. Logs, error messages, versions of the installed components etc.

HA Version 2023.7.2
Flower Card Version 2.1.0
Card tools Version 11

I get no erros or log entries :disappointed:

I just released an updated beta version of the flower-card as well.
This beta does no longer depend on cardTools, and ot can be set up from the GUI.

1 Like

That’s a huge achievement. Amazing work!

Is there any guide for newbies to install this addon?

I just install the card but I do not know how to manage the entities to be able to add it to dashboard, and after a first read of this thread it seems like whole “OpenPlantBook” installation are required.

1 Like

The instructions on the GitHub page are still valid.

  1. Create a free account at OpenPlantBook
  2. Install the OpenPlantBook Integration (install from HACS, then install in Settings / Integrations) using the client id and secret from the OpenPlantBook login area as explained in the docs here.
  3. Install the custom plant Integration
  4. Install the flower card
  5. Create plants in the custom plant Integration in HA Settings area. When you create the plant, use a “species” that exists in OpenPlantBook (website) and the Integration will automatically get all the info (picture, water/light/nuttrient requirements etc.)
  6. Setup the flower card using the Plant as created in your custom Plant Integration.

Hopefully I have that right, I’ve only just started using this myself.


Thank you!

Your plant integration is a huge improvement over the plant integration that is built into Home Assistant.

This integration is an improvement. I installed it today, and almost everything looks good.
But for both devices I use I do not get a value for the illuminance. I use the XIAOMI plant sensors. All others like moisture are visible.
Is any hint to solve this problem?
I use the integration, the Openplantbook and the custom card.

I had followed Olen instructions to install OpenPlantBook API (steps 1&2) and flower card (step 4), but remainig steps are still ongoing as:

  • I am not being able to install custom plant integration (step 3).
  • Nor being able to find where is the UI to search for plants, neither setup them.
  • It is not possible to find any Olen repository in HACS in my HA.

How can I add my plant and the data from sensors to flower card??

So have you followed these steps?


  • Add this repo as a “Custom repository” with type “Integration”
  • Click “Install” in the new “Home Assistant Plant” card in HACS.
  • Install
  • Restart Home Assistant

I searched for my plants inside the OpenPlantBook website. From there you can then get the eact species name for the plant and use that in the Integration to create your plant entity.