New virtual appliance : Home Assistant wont start

Tags: #<Tag:0x00007f3265f01e70> #<Tag:0x00007f3265f01d80>

I have been running Home Assistant supervised on a generic Linux install for a long time, but at some point I lost the ability to upgrade HA successfully. So I decided to start with a fresh install, and, since the generic Linux install is not supported anymore, I downloaded the latest supported virtual appliance image (V4.12 qcow), attached it to a suitably sized VM and started it as per the installation instructions.

The VM boots successfully, and I get a login prompt on the console. I can log in as root, and then see a “ha>” prompt. According to the installation instructions, the image should now download the latest HA, configure it and eventually present the UI at port 8123.

However it never seems to do anything after startup. CPU usage is idle and the UI never becomes accessible. When I type “os info” at the console prompt, I get : “Get http://supervisor/os/info: dial tcp 172.30.32.2:80: connect: connection refused”.

I can drop into the underlying OS with “login” but I am unable to locate any logs that might help with troubleshooting, and the documentation does not contain any troubleshooting guidelines for the image as far as I can tell.

Networking is fully operational and I can ping servers on the internet.

“docker ps” shows five containers running, and I can get a shell inside them with “docker exec”, but again I am stuck not knowing what normal operation should look like and where any logs are located that might help with troubleshooting.

Any guidance as to where to start troubleshooting would be appreciated.

I am having the same problem with the same exact symptoms as you. Have you had any luck with this since posting?

I’m running in VMware Workstation Player 15.5.6 btw.

Glad to report that I solved the problem with the gracious assistance of the folks in the homeassistant_os Discord channel.

First, I logged into the console as root (no password) and then dropped into the underlying O/S by typing login.

Next I used docker ps to determine the running containers, and noted the id of the Supervisor container - homeassistant/amd64-hassio-supervisor.

Next, displayed the container logfile with docker logs -f <containerid>

The logs showed a recurring error where the supervisor was truing to pull the latest homeassistant image from the docker registry, but failing with a 500- Internal Server Error on: get https //registry-1.docker.io/v2/homeassistant/qemux86-64-homeassistant/manifests/landingpage

The error message also complained about an i/o error on port 53 communicating with my internal nameserver. (Unfortunately my Proxmox console does not have cut/paste capabilities, so cannot paste the full error message here).

Apparently the DNS failure problem is a somewhat common issue with docker. I added an external nameserver in /etc/resolv.conf, and immediately the supervisor started to download the homeassistant image successfully. From there on, Homeassistant configured itself and was soon up-and-running.

The strange thing is that DNS lookups worked fine from the commandline, so I did not suspect DNS at all before seeing the docker logs.

A ‘permanent fix’ according to the docker forums is to create /etc/docker/daemon.json and add a dns entry for an external nameserver there.

I believe the docker DNS issue may be behind many of the homeassistant ‘fails to start’ issues, since it is such a complete blocker, and everything starts working as soon as it is fixed,

2 Likes