New x86-64 installation does not want to boot

New user here, first Home Assistant installation and it does not want to boot on my purpose bought mini industrial PC (Nexcom Nife, AMI Bios )
Bios is set to UEFI and no Secure Boot.
Managed to flash the Sata SSD drive fine :
Disk /dev/sda: 238,47 GiB, 256060514304 bytes, 500118192 sectors
Disk model: Samsung SSD 850
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: F2E29D92-E79B-4F50-A81F-D272F0C649D8

Device Start End Sectors Size Type
/dev/sda1 2048 67583 65536 32M EFI System
/dev/sda2 67584 116735 49152 24M Linux filesystem
/dev/sda3 116736 641023 524288 256M Linux filesystem
/dev/sda4 641024 690175 49152 24M Linux filesystem
/dev/sda5 690176 1214463 524288 256M Linux filesystem
/dev/sda6 1214464 1230847 16384 8M Linux filesystem
/dev/sda7 1230848 1427455 196608 96M Linux filesystem
/dev/sda8 1427456 4048895 2621440 1,3G Linux filesystem
/dev/sda9 4048896 12580863 8531968 4,1G Linux filesystem

At boot however, the system drops into the recovery UEFI Shell because it cannot find anything bootable.

A Live Ubuntu shows :
sudo efibootmgr --verbose

BootCurrent: 0004
Timeout: 1 seconds
BootOrder: 0000,0004,0003
Boot0000* HAOS HD(1,GPT,b3dd0952-733c-4c88-8cba-cab9b8b4377f,0x800,0x10000)/File(\EFI\BOOT\bootx64.efi)
Boot0003 UEFI: Built-in EFI Shell VenMedia(5023b95c-db26-429b-a648-bd47664c8012)…BO
Boot0004* UEFI: USB DISK 2.0 DL07 PciRoot(0x0)/Pci(0x1d,0x0)/USB(1,0)/USB(1,0)/HD(2,GPT,f45e2fa1-c5a6-4d79-876d-c8245af921e0,0x95f864,0x2754)…BO

The content of \EFI\BOOT is :
grub.cfg
grubenv
bootaa64.efi

The command
sudo efibootmgr --create --disk /dev/sda --part 1 --label “HAOS” --loader ‘\EFI\BOOT\bootx64.efi’
was executed successfully and HAOS indeed shows up as the first OS that should boot, but, after restart it does not boot.

Suggestions ?

Can you share screenshot of your BIOS where boot devices are assigned.

Sure, real ‘camera’ shots from the screen

The Boot Sequence :

Only Booting in UEFI (no Legacy) :

The Bios itself :

Have you tried to disable option #2 and leave only HAOS as the boot option. Also if possible can your share screenshot of the boot options available to select from.

List of available Boot Options :

Boot option #2 disabled :

No difference I’m immediately
dropped into the EFI Shell :

Does this Bios not recognize HAOS as a true EFI option ?
I understand that the file system requirement for a bootable EFI partition is FAT32 and is at least 100 MiB
However, HAOS has formatted it’s EFI partition with FAT16 and is only 32MiB big ?
(see EFI system partition - ArchWiki )

If you have time can you please follow my guide and let me know if it worked for you or not. Have you possibly prepared the HAOS disk on another system?

I have followed all the guides (the 4 I can find) to install on a x86 system.
They are all variants on how to get the HAOS image on the (main) drive.
They ALL work, up until the point I need to reboot and then HAOS does not start up.
All guides assume setting UEFI boot and no-secure boot is enough to then pick up the HAOS as first boot.

Even your guide details everything up until the point of final restart.
My system seems to be proof that that is not always enough ?

Can you try to install Debian or Ubuntu on the SSD, then try to boot. I use Ventoy which will also be useful to double test your system.