New ZWave switch not responding to commands

I just installed my first ZWave device, a Linear WD500Z-1 switch, today and I got it to be recognized in HASS where I now see it appearing in 2 cards - one on the “ZWave” card with my Aeotec transmitter where it says “Ready” and another on a “Light” card where it has an on/off toggle.

However, when I try clicking the on/off toggle or changing the dimming after clicking on that record, no changes happen to the lights/switch.

The process I used to add the switch was via the HASS GUI, I clicked on Add Node and then simply renamed it and restarted HASS.

Any suggestions?

It could possibly be two things:

  1. The device was added but the interview process didn’t complete. This usually happens if the device is quite some distance from your main controller. If you have a aeotec usb stick it’s best to hold it close to the device you’re trying to add during inclusion.

  2. If the switch is a secure device and you tried to add it securely then you need to make sure that you have uncommented the encryption key which you will find in options.xml inside your open zwave directory. Without this the controller and node won’t be able to talk to each other.

Also although HA offers the ability to add zwave devices via the UI now I always find it’s much more stable to add the device using the open zwave control panel. As it gives you a lot more options and it’s easier to figure out what is going on when things don’t work.

Try those first two points and let me know if you have any luck.

I ended up connecting with a couple of folks on IRC who suggested that the autodiscover process worked but it wasn’t actually paired. So I ended up resetting the z-stick (since this was my only node) and went through the pairing process again.

The important detail is that while the instructions on the Linear switches said to tap the switch once to pair, it seems as though you need to tap it twice. This was suggested to me and I also found other reports of the same thing online. So after doing the double tap to pair, I was able to successfully manage the switch from hass.