Newb, Expose HomeKit devices to home assistant (ie shelled flashed with homekit firmware)

Hi all! super new to home assistant.

im trying to integrate it with my current homekit setup. i have managed to expose the home assistant entities to homekit via the homekit integration. so far all is perfect

my question is the other way. i have many devices (such as the shelly switches i flashed with homekit firmware: GitHub - mongoose-os-apps/shelly-homekit: Apple HomeKit firmware for Shelly switches) that i want to also expose to home assistant

How (and if all possible) does one do so? i have tried the homekit controller integration but that dosent seem to show\find any of my homekit devices

any info would be super appreciated!



I have no clue if that would be possible. Doesn’t the Shelly integration fit your needs?

thx @pedolsky

yes its just I already flashed all the Shellys with custom firmware and to lazy I guess to reflash…though I heard somewhere I can add homekit devices to home assistant. the homekit controller dosent seem to be working for me

thx again


The HomeKit Controller integration is the way to add HomeKit devices to Home Assistant, so if that doesn’t work it’s going to be difficult.

thx @robertklep , appreciate the help

for some reason every time I try to add the Controller integration it just says it cant find anything:

CleanShot 2022-05-07 at 16.17.20

I have many devices natively in the homekit app and via home bridge so im not sure what im doing wrong… would really appreciate any help from you guys as a newer as im completely stuck :smiley:

thx so much


No unpaired devices could be found. HomeKit devices can only be paired with one controller, so if you want to add them to Home Assistant, you need to unpair them from your iDevice first.

thx again @robertklep, so that’s what I tried to do. I unpaired one if my shelly PM2.5 from homekit and did a search yet nothing was found…thats why I am a bit confused. thx so much again


Perhaps you need to reset the device in some way? It may not be enough to just remove it from the Home app.

thx @robertklep ! doing a full rest did the trick!!

thx again


1 Like