Newbie first questions

Good afternoon

Well I make the mistake to learn home assistant in raspberry pi4. This opens many jobs for me since isn’t so easy …guess for you is easier?

First I am trying to add those xiaomi humidity sensor. I click reconfigure …I find the blind key with the flasher, I install my own blind key…it says the blind key doesn’t work. Any thoughts?

I am trying to add only the smart button from ikea. I have the tradfri dimmer(the one writing I and 0),the ikea smart button with one click and the tradfri remote control. Probably I must buy an zigbee usb stick?! If yes then which of them will work?! The sonoff zigbee usb is a good option?! I have also the ikea bridge…but it doesn’t work with alexa…it needs lamps Ikea also. It will work with home assistant with all my remotes?!

After that about my Philips hue dimmers and tap dial. I have them with xiaomi lights through alexa.I have also the Philips bridge. I can see them in the home assistant….but can I configure them?! Or I must have the zigbee antenna without the Philips bridge in order to configure ? The problem is that Alexa doesn’t have all the option…like the tap dial have a function that each button have two pushing option …the simple press and the holding press. So I am wondering if now I can use all the functions.

Last but no least I try to connect to my home assistant from a distance but maybe I need to do someth8ng in settings?!


  1. So, as I understood you just start with Home Assistant in a Raspberry Pi and the basic functionalities ofmyour Home Assistant are working properly, is that right?

  2. You are trying to pair Zigbee devices, is that correct?
    2.1. Do you have a USB Zigbee dongle? Which one?
    2.2. Which Zigbee integration are you using? ZHA, Zigbee2MQTT, DeconZ, etc?

If you want to use Zigbee devices, that is my suggested approach. Also, apart of the Zigbee usb dongle, buy also an usb extension cable.

It is a good option. Be aware that there are two different versions available and you should select the o né will best fit your Zigbee integration.
There are plenty of options for Zigbee usb dongle… Take a look in the many community topics related to this, like this one here.

Yes, there is an integration for the Ikea gateway here.

I think you should create another topic for this… It is c8nfusing when we are talking about everything in the same topic.

1 Like

I’m not going to link them all here because that seems like it would be too much like spam, but… Nearly every question you’ve asked - from zigbee, to external access, and more - I have made instructional videos about on my YouTube channel. Go and give them a watch, I’m sure they will help you. The zigbee video was just last night.

As for the sonoff zigbee stick, I know a lot of people have them, but… I tried one, and it was horrible. Maybe I just got a bum one, but it would pair devices, and then wouldn’t get any updates from them. Worthless. My old one was a conbee II, and I thought the sonoff would be an upgrade. I was disappointed. Ended up going with a go control stick that does both zigbee and zwave (discussed in the video).

Here’s a link to my channel. The zigbee video is right on top, published yesterday. The remote access videos are a bit further down, from last summer maybe? There are a couple different methods, each with their own video.

Hope this helps!

1.Yeah most of them works properly

2.I don’t have zigbee dongle. I put the bridge Philips but I don’t know if I can configure the remotes with that way. I don’t know about zigbee Intergration since I don’t use something for now.
So which version of sonoff should I choose ?! I find the sonoff zigbee plus 3.0.

ABout Ikea integration …also in Alexa I have the oportunity to add Ikea But….since I didnt have Ikea lights I can not use the remotes. Is the same situation adding Ikea remotes with the Ikea getaway to home assistant through Ikea intergration?!

Thanx for the info exx I would check it for sure.

ps: I make everything until it says assistant container… Raspberry Pi - Home Assistant. Are necessary all the rest?!

so I make some steps more.

1a. I can use the philips remotes and tap dial with all function with the philips bridge. so good news.
1b. I use now the rotation function but I don’t how move to increase brightness with more speed. I make 3 turns in order to go 100% and its annoying.

2.I can’t connect my tapo plug. I find some repositories but they don’t work. I have a kasa plug and it works pretty good.

  1. I can’t connect my xiaomi desk lamp for a reason. the system finds my Xiaomi lamps automatic but not the desk lamp. I make searching again but nothing happens. maybe I have the number 13 In my neck?!

  2. I also have a lamp that is connecting through smart life lamp. it needs tuya account. I follow one video on YouTube but I stuck somewhere. I can find the plan to choose the free trial.

5, the xiaomi thermometer problem still exists.

be my guest to help me in my home assistant progression.

thanx in advance

Tuya can be quite the trouble. I was never able to get my Cloud API account with them to work, so instead, I followed this video for finding Tuya Local Keys and Device IDs: HOW TO - Get All Local Tuya Keys (ALL KEYS, SIMPLE, NO SOLDERING) - YouTube and then, used those to set up the LocalTuya custom integration from HACS or here: GitHub - rospogrigio/localtuya: local handling for Tuya devices

I’m afraid I don’t have any Xiaomi devices, so I won’t be able to help with those.

1 Like

Yes. With the Ikea gateway, you can only add the remotes to another Ikea device. If you want to use them independently, you need a Zigbee stick

1 Like

Are you controlling it via Home Assistant? If so,mplease share your yaml so we can understand your approach and propose something.

Share the reps you have tried and which error you have…

Anyways there is one integration on HACS that looks quite promising:

How are you trying to connect and which error message you got?

Please take a look at this discussion:

What is the problem and how are you trying t8 connect it?
Which model is your thermometer? Do you have at list a link for the device in Amazon or other place where we could try to understand which device it is?

1 Like

thanx guys…I thought that I am lost and alone.

francisp so with philips hue bridge I can use my hue remotes independently. I was thinking this will be the same with ikea?! why not?! so why I must take a Zigbee since I have the bridge?!

foreverimagining about tuya…I follow the same guy but with older video. I didn’t know that he makes a new. the tuya changes the account method…so I will try. thanx for the info

EdwardTFN. I will share my yaml in another time since it seems a little bit tricky. I don’t know how to do it. So I will make a searching for that.

for tappo I add the GitHub link that you send me. I go to settings-addons when 3 dots repositories and I add the GitHub - petretiandrea/home-assistant-tapo-p100: A custom integration to control Tapo devices from home assistant. . It says that is not valid.

for Xiaomi desk lamp I don’t take a message or something…since the home assiastant can’t find it at all.

for xiaomi sensors . They are working via bluetooth. it needs a blindkey. there is a flasher what takes the blindkey or you enter your own. I follow a video nothing happens. I press reconfigure to xiaomi sensors…I place the blindkey …and it says something like that “blindkey doesn’t work. check It and try again”

Don’t ask me, ask Ikea. That is the way they designed their system.

well hello again.

tapo plug: I still have problem. I put some repositories but they don’t work.
xiaomi sensors: I still can’t put them. always says blindkey don’t work.
xiaomi desk lamp: I make it through the HomeKit.
tuya device: I quit of it. I find a way to do it…but is for android. so I quit.
philips rotation function: it works but as I understand it works as a button. If you rotate to left is one click and you must wait for a while to rotate it again. it doesn’t matter if you rotate it a half circle or one click.

any thoughts?

Which one are you talking about ? I have Xiaomi Zigbee and Xiaomi bluetooth ones.

the xiaomi bluetooth is that I am talking about.

Did you flash them ?

yeah I flash them and I can’t connect to it.

I have the raspberry pi…maybe the bluetooth on raspberry don’t work properly for a reason?!

but its says when I upload the firmware file the following

Invalid size pointer in Telink OTA binary firmware!