Newbie idiot to HA and ZHA, currently battling LEDVANCE Bulbs

Sadly there are no logs that show up that the ZHA search for new devices did not find anything.

I am not sure how you would like me to describe this in more detail.

Hi Bartem.

Thanks for the message. I reset one of the bulbs now. The bulbs cycles through colours, blue, red and green and then goes to steady white. Did several searches on ZHA and it didn’t detect the bulb.

I got some Zigbee motion sensors which ZHA does detect.

Could LEDVANCE have bulbs that are not Zigbee?

Thanks Al.

Hi Grom. I tried removing them from Alexa. Sadly same result. I am starting to. Think I was duped on the LEDVANCE bulbs.

Ledvance has zigbee, wifi, and Bluetooth bulbs… there is a sylvania app for each respective type of bulb. Do you not have the packaging?
I had some sylvania WiFi bulbs I bought on accident and was able to use localtuya to control them…

Hi Bartem, I have some of the smart wifi plus bulbs too and was wondering how you got them to connect ?

Thanks but how did you get the bulbs connected to the tuya app ? mine are connected to the silvania app /the ledvance smart wifi app.

There is instructions in the linked post… the first link takes you to the thread which talks about it… the second takes you to the GitHub repo that has instructions

Yeah I saw that but it doesnt say how to link the wifi bulbs to the tuya app does it ?

I tried that but the tuya cli just doesnt find the bulbs, got any idea why ?
that’s the error I get

× Device(s) failed to be registered!
Error: Timed out waiting for devices to connect.
    at TuyaLinkWizard.linkDevice (C:\Users\krona\AppData\Roaming\npm\node_modules\@tuyapi\cli\node_modules\@tuyapi\link\index.js:117:17)
    at runMicrotasks (<anonymous>)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async link (C:\Users\krona\AppData\Roaming\npm\node_modules\@tuyapi\cli\lib\link.js:47:19)

There is a list of possible causes for that error in the troubleshooting section of the repo

Yeah I tried all those steps, but it sadly still doesnt work, do you have any ideas what I could do ?

Try reading this post and a few posts after it also…

a few people mention having to reset the bulbs a couple times in order to get them to “fast blink”… also when I did it I ended up doing it only one bulb at a time which seemed to work a little better.

I tried resetting it about 10 times already and 1 at a time too, I guess its just not supposed to work

What command are you using the tuya-cli wizard or the tuya-cli link

tuya-cli link --ssid network name --password password --api-key apikey --api-secret api secret --schema shema --region eu

And I am getting the api key and api secret from the tuya iot plattform website

I’m not sure why it is not working for you. For me my bulbs were upstairs, and as mentioned in one of those other threads that initial pairing connection is happening directly to the bulb from the device you are running tuya-cli on before it sends your SSID and password to the bulb so what I ended up doing was taking a laptop into the room with the bulbs and
running tuya-cli directly under the bulbs… I could never get all 3 to go at once so that’s why I ended up doing one at a time.

Do you have any info on the bulbs? Like a specific model/revision number on them? It isn’t out of the realm of possibility that some are coming with different chips than the original run that most people had. Also had you completely removed them from the sylvania smart life app?

Yeah I completely removed them from the app and my Model Number is LDVWIFIA100E27RGBW. I hope that helps and if its not the model number I would appreciate it if you could tell me where to find the model number.

I am also sitting right under the Bulbs with my computer.

I am having similar issue, I am running HA with a sonoff usb zigbee dongle, just bought a ledvance smart+ lighting zigbee, reseted it (it is blinking), but HA can’t find it. Do you have a solution for this?

Update Zigbee Coordinator firmware and use a long USB extension cable + follow general advice. See: