Newbie issues with connecting with Putty or FTP

I am trying to get Putty or something working so I can access folders on Home assistant from my windows machine.

I have DuckDNS set up and running and I can access the frontend, However I would like to add some of the custom UI cards and I cannot seem to get the FTP or Putty connection to work I installed this back in April, then is sat for a while and I just started to look at it more and would like to get that last piece setup…

Firstly, what version of HA are you running?

If you have a version that uses the Supervisor, you can install the ‘SSH & Web Terminal’ add-on and use that to connect to the machine via Putty.

If you are running a version that does not use the Supervisor, then make sure openssh-server is installed on the machine, and connect via port 22.

Yes I assume if I see ‘Supervisor’ on the left and I am able to install add-ons, I am using the supervisor version. I have installed SSH & Web terminal , with no luck connecting.

Supervisor version is 247 and Host is HassOS 4.14

to access I am using duckdns and the only way to access the UI is ( I need to the 8123 for both the IP or hostname

Here is the newbie question, how do I install openssh-server on the machine?

If that is all you need, install the samba addon and access your files with explorer \\\ :wink:

I tried the Samba too… no luck… but maybe i am not formatting the info in explorer correctly

everything I tried say I cannot access it

Just noticed a double backslash is a format code here… it should be:
It should then ask for credentials , you can use your HA username/password

yep… getting further… now it works … huh was not working before…

SSH still not working though, that would be nice as well