Newbie Pi 3B+ Installation Problem


Just tried installing (via manual install instructions at

After entering pip3 install homeassistant, I get an exception very quickly after Collecting astra1==1.6.1 (from homeassistant).

Tried removing the venv and reinstalling… same problem. I’m just learning Python, so I don’t know too much more.

Any help would be greatly appreciated.

Attached is the terminal output from the install commands (starting with wheel):

Remote End closed connection without a response means pretty much what it says. There is some kind of network problem. Somebody else was experiencing this a few days ago, so it could be the server is having some capacity issues. See

Just hacking at the problem, i just did a pip install homeassistant instead of pip3. Seems to be working.

Now if I can just get my automation.yaml file set up properly :grimacing:

1 Like

So, I see the problem is the documentation which says to use the command:

pip3 install home-assistant

But, it should be:

python3 -m pip install home-assistant

I recommended a change to the documentation


Oops. Should obviously be home-assistant. So much for predictive input and 25 years of using Homseer. :upside_down_face: