Newbie - problem with starting z-wave


At start i must say i dont have experience with linux based systems, and with Pi3 generally, but im not scared of learning new things :slight_smile:
Today i got my Pi3, and installed HomeAssistant (All In One installer, following great guide at

What i got:

  • Pi3 with HA running on it, with static ip adress in my local network
  • i can get at HA web page - but only by ip adress with :8123 port. Typing in browser http://hassio.local:8123 does not work
  • installed addons - updater, samba, ssh
  • i can connect by ssh, im logging in as root
  • i do have aeotec z-stick plugged into Pi3

What i tried, but it does not work: I tried to follow this guide to install z-wave: but do have problems. Some details:

  • command: sudo apt-get install libudev-dev does not work, im getting “sudo: not found”. Ok… im a root already, so it makes sense, but command apt-get install libudev-dev does not work ass well, with “apt-get: not found” result
  • command: ls /dev/ttyACM* giving result “no such file or directory”

I added anyway a
usb_path: /dev/ttyUSB0

section at end of my yaml file, as result im getting info about invalid config (The following components and platforms could not be set up: zwave. Please check your config)
And now im stuck… Any idea what im doing wrong ?


For z-wave in hassio, see You should only need to add this:

  usb_path: /dev/ttyACM0

Its working ! Thank you :slight_smile:

Z-Wave is working indeed, but at “history” screen oh HomeAssistant i do see entry “Invalid config” with “The following components and platforms could not be set up: * zwave Please check your config” message as still active. Should i ignore it ?
My z-wave config in yaml file is:

usb_path: /dev/ttyACM0

(thx NotoriousBDG), and thats all.