Nextcloud Intergration

Hi All,

I can’t let nextcloud let work in HA.
Tried everything. Have self signed ssl cert. Because Letscrypt isn’t work. Port 80 and 443 directed to my HA RPi.

Tried many URL’s:


this is working also. I get output:

Username and app password are active in Nextcloud. Monitor App is active in Nextcloud

The Nextcloud Backup Integration (
) is working. There you can ignore SSL check.

Hya, i’m getting the following error.

My nextclound is using a self generated cert with a own root cert (my own CA). How to make it be recognized?

root@wolke:/var/homeassistant/homeassistant# cat home-assistant.log 
2020-06-25 08:42:54 ERROR (SyncWorker_16) [homeassistant.components.nextcloud] Nextcloud setup failed - Check configuration
2020-06-25 08:42:54 ERROR (MainThread) [homeassistant.setup] Error during setup of component nextcloud
Traceback (most recent call last):
  File "/var/homeassistant/lib/python3.7/site-packages/homeassistant/", line 190, in _async_setup_component
    result = await asyncio.wait_for(task, SLOW_SETUP_MAX_WAIT)
  File "/usr/local/lib/python3.7/asyncio/", line 416, in wait_for
    return fut.result()
  File "/usr/local/lib/python3.7/concurrent/futures/", line 57, in run
    result = self.fn(*self.args, **self.kwargs)
  File "/var/homeassistant/lib/python3.7/site-packages/homeassistant/components/nextcloud/", line 102, in setup[DOMAIN] = get_data_points(
UnboundLocalError: local variable 'ncm' referenced before assignment
2020-06-25 08:42:54 WARNING (zeroconf-ServiceBrowser__ipp._tcp.local.-_miio._udp.local.-_ipps._tcp.local.-_wled._tcp.local.-_elg._tcp.local.-_daap._tcp.local.-_api._udp.local.-_googlecast._tcp.local.-_viziocast._tcp.local.-_spotify-connect._tcp.local.-_dkapi._tcp.local.-_esphomelib._tcp.local.-_hap._tcp.local.-_axis-video._tcp.local.-_printer._tcp.local._140189494146816) [zeroconf] Error sending through socket 11
Traceback (most recent call last):
  File "/var/homeassistant/lib/python3.7/site-packages/zeroconf/", line 2792, in send
    bytes_sent = s.sendto(packet, 0, (real_addr, port))
OSError: [Errno 126] Required key not available

2020-06-25 09:35:09 ERROR (MainThread) [homeassistant.core] Error doing job: SSL error in data received
Traceback (most recent call last):
  File "/usr/local/lib/python3.7/asyncio/", line 526, in data_received
    ssldata, appdata = self._sslpipe.feed_ssldata(data)
  File "/usr/local/lib/python3.7/asyncio/", line 207, in feed_ssldata
  File "/usr/local/lib/python3.7/", line 767, in unwrap
    return self._sslobj.shutdown()
ssl.SSLError: [SSL: KRB5_S_INIT] application data after close notify (_ssl.c:2609)

Thank you for any assistance.