NFC/RFID for that initial presence detection

I’m now running the fantastic HASS Custom Alarm Interface but one thing I’m coming up against is my presence detection is not fast enough to disarm the alarm before it’s triggered. I’d rather my wife didn’t have to use a keypad on a wall tablet to disarm the alarm. It would drive her batty and lead very swiftly to its dismantlement and removal.

I’m using the Life360 component and Monitor. Monitor used to be SUPER quick at detecting presence but it’s now slower than Life360! It gets there, but it’s a few minutes behind. I don’t know what’s happened. I’m using default settings and a clean install. I’ve tried the beta branch and the master branch. Previously when I last used Monitor in Autumn last year on the exact self same settings it was lightning fast at detecting me.

Anyawy it got me thinking. Would it be possible to mount a NFC sensor next to the lock so that as a resident goes to put their key in the lock to unlock the door, the NFC sensor picks up the presence of a tag on the keychain and notifies HA to disarm? Anyone doing this at the moment?


1 Like

I have the opposite: a NFC tag and with the smartphone and an app called HA NFC, which basically gets the NFC commands and translates it into a HASS service.

Then I bought this, but have not installed it yet (I lost it somewhere in the house … sigh), which should do exactly what you want

or you build it yourself buying something like this, and attaching it a ESP8266 inside (I have it, but its a postpooned project, no time for it).
Its both keypad and TAG reader, so when you pass your tag it gets the command, the command is passed to the ESP8266 which is then red by HASS

Maybe I’m barking up the wrong tree. I wanted NFC because I thought it would work with mine and my wife’s iPhones but looking at some NFC vs RFID explanations online it looks like I’d be better off with RFID because then it will have the range to work through the stout wooden door.

I highly recommend this bluetooth solution. Buy a Pi Zero W, put it near the front door and respond to the MQTT messages when people arrive.

Thanks @michaelblight but I’m having problems with Monitor at the moment. Don’t know why. As I said I’m using default settings and a clean install. This used to work really quickly but now doesn’t -don’t know why.

Oops, after reading down through all the replies I forgot you were already using it.

I found the default behaviour a bit confusing with Monitor, so I changed it to respond to ARRIVE and DEPART messages that I control (ie. I’m using -tad -a). I’m sending these every minute because that suits my use case, and since then have found it rock solid and easier to understand. I also use the responses as a heartbeat and automatically reboot through SSH if they stop responding (hasn’t happened much lately).

I should add that my 2 Pi Zeroes and a Pi 3B+ that it runs on were dying every few days until I bought the official power supply.

1 Like

I’m looking into adding ‘Monitor’ to my house (wifi coverage isnt great so I’d have a bluetooth network to fall back on for presence) and I’d like to thank you for a simpler setup example. :slight_smile:
As a new user to the idea of Monitor that thread is a REALLY daunting read…

Hi Coedy - be aware if your wifi coverage is patchy at the moment, adding Monitor may make things worse! Apparently (just learned this) using an off board WiFi Dongle on the Pi can help?

Really is not that difficult, just follow original instructions (not the thread that may confuse you.

Follow this ( Installation Instructions for Raspberry Pi Zero W) you can of course also use other linux machines (pi3 or other)

then to make sure you have no errors

sudo bash

Then put your mqtt server data here

sudo nano mqtt_preferences

and your devices data here

sudo nano known_static_addresses

and your devices data here

sudo nano mqtt_aliases
1 Like

I suggest also to do this, to receive also rssi (signal level) of bluetooth connection

  1. Stop monitor service:

    sudo systemctl stop monitor

  2. Run monitor with -c flag, followed by the mac address of the known_device to connect:

    sudo bash -c 00:11:22:33:44:55

1 Like

Thanks, I had noticed that when I had the Bluetooth device tracker enabled on the pi it negatively impacted the Wifi (but thought that may just be a strange Pi but, rather than Bluetooth bug).
I had also considered just using monitor to run arrival/departure scans based on a door sensor, I’m hoping that that will overcome the fact myself and the wife’s phone batteries aren’t great. so its likely our phones will die in the evening, but we would come home with some battery, and we wouldn’t leave the house without our (charged) phones.