NFC Tag Issues


Having installed 0.114 and the latest iOS app 2020.5.1, I was excited to give NFC tags a go. I created a tag ID, and created and automation to trigger it.

(I replaced the last parts of the ID’s with x’s)

- id: 'A945E4DD-ED8D-442E-AE49-xxxxxxxxxxxx'
  alias: "Trigger NFC Event - Study"

  - platform: event
    event_type: tag_scanned
      device_id: 178D8E87-2945-43C6-9507-xxxxxxxxxxx
      tag_id: 582ffae5-17f3-472a-af63-xxxxxxxxxxxx

  - service: notify.slack_channel
      message: "NFC Tag Scanned"

Tapping “Fire Event” on my phone triggers the automation correctly.

However, when I tap the NFC tag, I get the notification at the top (described on which seems to be of the correct format (, however this doesn’t load the iOS app, it gives me a “Page Not Found” on the website.

I’m pretty sure I’m missing something simple, would anyone be able to please point me in the right direction?

Thanks in advance!

  • James.

This is an area that we could improve the documentation for. We can also make that page not 404 and instead offer a “long press here to turn on Universal Links” (which would fix this). Filed this part on GitHub.

What’s happening is the Universal Links setup on the system isn’t opening the app for /tag/…. The system will irregularly update the list of domains the app supports (so it will eventually start to work). One way to kick-start it is to delete and reinstall the app, but hopefully you won’t need to do that.

Sure enough, it worked great when I got up this morning.
Time is a healer lol. Thanks @Zacwest :pray:t2:

Does it work with Iphone 7? I can write and read NFC tag via HA Companion, but can’t fire the event.

Just tried this today on my iPhone 7 and the only way to get it to fire is to press the fire button after reading the tag


I guess the newer phones can trigger an automation using the shortcuts app but older phones will always have this limitation.

did anyone ever solve this? I have an iphone 10 and can’t get it to read tags without actually using the mobile app to press read tag and then pressing fire event

Same issue here - iPhone X does not have background NFC reading meaning you need a tag reader app to scan the tag which should then open up the home assistant app.