All, i’m struggeling with my Hassio set up.

I have installed duckdns a year ago and had to make a few line’s in my config file:


ssl_certificate: /ssl/fullchain.pem
ssl_key: /ssl/privkey.pem

I want to use NGNIX and removed the http lines from my config ( I started using the duckdns add-on).
but without these lines I cannot acces my HA via duckdns anymore. Putting http/ssl cert &key back resolves this issue but is not the way it should be set-up. NGNIX also requires to remove the ssl lines from the config.

Pulling my hare… what am I doing wrong?

NB I read that duckdns creates a ssl file but I cannot find this in my HA… Looks that this might be te problem but how to fix?

If you just remove those three lines then you should still be able to access HA using the local IP and port, eg If that works then you just need to check that:

  1. The port forwarding now is to NGINX not HA
  2. NGINX is correctly configured

Hi! thx for your reply! I can acces via the local IP (https…)
NGINX works (log files are clean, Ok result).

What do you mean bij port forward is to nginx? I have an asus router and just logged in (port forward on screen) but do not know what to do… Can you advice? I now have a port forward from 443 > 8123 .

BTW what about the ssl files? they are nowhere to be found :frowning:

Currently your port forward is to Home Assistant. You’re (apparently) wanting to use NGINX for SSL, so you need to:

  1. Change the port forwarding to point to NGINX
  2. Configure NGINX to forward the traffic to HA

The add-on I believe creates the certs in /ssl/ if you’ve enabled Lets Encrypt and configured things correctly. I don’t use it though.

Tried first to remove the config lines ( http and ssl) and reinstall duckdns to see if I can get it to work as being described in the docs. Result: no external entry via my I want to solve this first before moving on to NGINX. How to solve? I don’t know what I’m doing wrong. Duckdns works fine but why do I still need the lines in my config file?

my setup:
NUC with ubuntu (16…)
Docker installed
Running Hassio in a container

If you’ve removed the SSL lines then you can’t use https://any more, only http://

Hi Tinkerer, thx for trying to help me out. Much appreciated. The http/https makes sense. I can acces my HA local and via duckdns external but according to the install inx I do not need the add the http and ssl lines in my config. But when I remove these lines from my config my duckdns stops working. Or should I remove the port forward 443>8123 from my router?

Remove the port forward you’ve currently got set up. Set up a new one pointing to NGINX, as I said back in NGNIX/duckdns

Solved! Works as designed :smile:. Many thx!

1 Like