Nmap configuration (home_interval)

Greetings, need some help with nmap component

Here is my config:

  - platform: nmap_tracker
    home_interval: 3

“home_interval (Optional): The number of minutes nmap will not scan this device, assuming it is home, in order to preserve the device battery.”
I guess, it should update every 3 minutes, but “6 min ago” (I turned off wi fi on phone)


I just tried it. My home interval is set to two minutes. It recognises I’m away four minutes after I turn off wifi on my phone. It’s unreliable, just like every other HA tracker.

Really works bad. Because wi fi on smartphone is turning off when you do not use it, nmap is getting wrong data. I can see how I am out of home and then again at home trough night. What can you advice? Which component will do the job?

None of them. HA is hopeless at this.

Some people find using a Bayesian sensor to combine multiple trackers works for them. Personally it’s just too much hassle.

Likewise this seems like a lot of effort:

Homekit presence works very reliable for me

1 Like

It did for me for a few days then started false alerting.

Yes, I read you’re not a big fan of the current HA presence detection components but that doesn’t mean it not working for all of us.


Great. Maybe it will work for Argo. Then again maybe it wont. What a wonderful product.

1 Like

I think you forgot to take your happy-pill this morning.


anwsering the original query, my config is:

  platform: nmap_tracker
  cosider_home: 600
  interval_seconds: 20
  home_interval: 10

I have iphones. Still get false away readings, but setting the home interval t 10 minutes helps reduce them.

Hope this helps

1 Like

Indeed. I’ve been battling HA all afternoon to get a simple Google Calendar event to trigger and it’s pissing me right off. Apologies for venting my frustrations with HA here.

Presence sensing is the base of home automation, and when this feature not working it makes the whole system unusable

For some reason this issue kind of ignored, for me personally this issue holds me back from moving all my stuff exclusively to HA so I must still use Xiaomi’s app

1 Like

Thank you for advice, will try it tonight

Actually, Monitor works great right out of the box if you have an MQTT server up and running. I have it installed on three Raspberry Pi 3Bs and then I have bayesian sensors that monitor the three bluetooth sensors that I create with Monitor, the nmap device tracker and the traccar client. I could probably get away with just Monitor, but I like the redundancy.

I’d like to try nmap, but I can’t find where I can get it for Hass.io. Can you please provide a link?

Thanks, I don’t know why, but I was looking for how to install it, instead it’s already included.
I’ll try it as soon as I’ll have some free time.

I tried nmap and I must say that it’s working near perfectly.
Here is my status for today:
I switched on plane mode at 1:55, then off at 9:34.
I went to buy food from 11:31 to 12:19.
I went to vote from 14:34 to 14:51.

There are only 2 false not_home with duration less than 1 minute: 18:03 to 18:03 and 20:27 to 20:27 (strange)

This is my device tracker setting:
- platform: nmap_tracker
home_interval: 1
consider_home: 90

My mobile is a Honor 9.