NMap errors

I’m using nmap device tracker on my and my girlfriend’s phone. But I notice Home Assistant is not detecting the correct presence state after a while. In the logs I keep seeing this error:

WARNING (MainThread) [homeassistant.components.device_tracker] Updating device list from legacy took longer than the scheduled scan interval 0:00:30

This used to be 12 seconds but I upped it to 30 seconds through the interval_seconds option. Both phones have a static IP address. My configuration looks like this:

  - platform: nmap_tracker
    home_interval: 5
    interval_seconds: 30

I’m running Home Assistant 0.99.3 on a PC running Ubuntu Server 18.04. HA runs through docker. In case this might be relevant, here is the docker-compose:

 version: "3"
     container_name: home-assistant
     image: homeassistant/home-assistant:stable
       - /home/pixel/.config/home-assistant:/config
       - PUID=1000
       - PGID=1004
       - TZ=Europe/Amsterdam
     restart: always
     network_mode: host

Update 10-12-2020: I just wanted to say I switched to monitor at the end of 2019. I use this in combination with bluetooth beacons connected to our keychains. The battery lasts for about a year, leaving home is detected within 2 minutes, but most importantly: coming home is detected instantly. It’s been stable for a long time now. I won’t be able to answer any DM’s or questions here regarding NMAP, ping or the dd-wrt integration.

Does this have anything to do with my router? It’s a somewhat older model (about 8 years old) flashed with DD-WRT.

I switched to ping, but unsuccesfully because it would just stop pinging. So I decided to try dd-wrt and didn’t have much succes at first. After changing wireless_only to false it worked great for both our phones. Which is strange since both devices are connected wirelessly, but whatever. Happy this finally works. :slight_smile:

Where did you put this option? I am facing the same issue.

In DD-WRT integration setting on HA :slight_smile:
Best, JR

1 Like