NMAP on Synology NAS

Has anyone get nmap to work on a Synology NAS?

I get this error:
17-02-21 18:34:05 INFO (MainThread) [homeassistant.components.device_tracker] Setting up device_tracker.nmap_tracker
17-02-21 18:34:05 INFO (Thread-4) [homeassistant.components.device_tracker.nmap_tracker] Scanning…
17-02-21 18:34:05 ERROR (MainThread) [homeassistant.components.device_tracker] Error setting up platform nmap_tracker
Traceback (most recent call last):
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/site-packages/homeassistant/components/device_tracker/init.py”, line 158, in async_setup_platform
None, platform.get_scanner, hass, {DOMAIN: p_config})
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/asyncio/futures.py”, line 358, in iter
yield self # This tells Task to wait for completion.
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/asyncio/tasks.py”, line 290, in _wakeup
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/asyncio/futures.py”, line 274, in result
raise self._exception
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/concurrent/futures/thread.py”, line 55, in run
result = self.fn(*self.args, **self.kwargs)
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/site-packages/homeassistant/components/device_tracker/nmap_tracker.py”, line 47, in get_scanner
scanner = NmapDeviceScanner(config[DOMAIN])
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/site-packages/homeassistant/components/device_tracker/nmap_tracker.py”, line 82, in init
self.success_init = self._update_info()
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/site-packages/homeassistant/util/init.py”, line 296, in wrapper
result = method(*args, **kwargs)
File “/volume1/@appstore/py3k/usr/local/lib/python3.5/site-packages/homeassistant/components/device_tracker/nmap_tracker.py”, line 110, in _update_info
scanner = PortScanner()
File “/volume1/homeassistant/deps/nmap/nmap.py”, line 131, in init
nmap.nmap.PortScannerError: ‘nmap program was not found in path. PATH is : /opt/bin:/opt/sbin:/sbin:/bin:/usr/sbin:/usr/bin:/usr/syno/sbin:/usr/syno/bin:/usr/local/sbin:/usr/local/bin’

Any help is very much appreciated!


There’s your problem :wink:

You’ll need to install nmap before it’ll work.

1 Like

Ok, but how? I have tried to install it (sudo ./python3 -m pip install nmap. Something is installed but I still got this error.

Thanks for your help!

nmap is not a python package, so you can’t install it that way.

A few seconds with Google found this and this. I don’t use Synology, so I can’t help further than pointing you at Google, and the Synology forums :wink:

Thank you for your answear, I really appreciated it!
But unfortunatly it doesn’t work. I have already tried what they suuggest on this pages.

But it didn’t supported my cpu in my NAS.

But thanks again :slight_smile:

Best bet then is to post on a Synology forum, remembering to provide details of your NAS model (and firmware revision etc) so that people can help you.

Yes I will try that. Thanks for the explanation how things work. I’m a newbe into this :slight_smile:

I was able to install ipkg which then allowed me to install nmap on synology nas using this approach: