NMAP problem

The nmap stopped setting me as home, and when I tried to troubleshooting with deleting the known_devices file, it wont make a new file.

  • did you check the logs
  • have you tried turning it off and on again
  • is nmap available as domain in the developer tools

-Yes, the logs shows no error, just nmap starting and scanning.
-Yes, even tried putting it in the main config file again (it was in a separate device_tracker file)
-I dont know what that means… ? But everything was working up to before the weekend…

Have you checked that the user you’re running HA as can write to that directory?

Edit to add - if it worked before the weekend, what have you changed?

I tried to make a backup button/script to HA, (from the forum), but I think I have removed it all, and just made som changes to the new backup folder I made.

What should the permissions be like?

(I tried deleting the log files also, and it keeps on reapperaring, so the permission should be ok?)

If the log file re-appears, then directory permissions are good.

You’re sure there’s nothing at all in the log? What if you touch known_devices.yaml as the user running HA and then restart HA?

17-02-19 20:27:04 INFO (Thread-3) [homeassistant.components.device_tracker.nmap_tracker] Scanning…
17-02-19 20:27:09 INFO (Thread-3) [homeassistant.components.device_tracker.nmap_tracker] nmap scan successful
17-02-19 20:27:09 INFO (Thread-3) [homeassistant.components.device_tracker.nmap_tracker] nmap scanner initialized
17-02-19 20:27:22 INFO (Thread-5) [homeassistant.components.device_tracker.nmap_tracker] Scanning…
17-02-19 20:27:28 INFO (Thread-5) [homeassistant.components.device_tracker.nmap_tracker] nmap scan successful

This is what I get in the log, the touch didnt make it work again. The know_devices was made, but dont get populated.

What does your device_tracker section of your configuration look like? Don’t forget to apply the preformatted text formatting to it, so we can spot missing/extra spaces etc.

- platform: nmap_tracker
  track_new_devices: yes

Also tried with indent on platform

The spacing could be a problem, since it should look like:

  - platform: netgear
    username: admin
    password: YOUR_PASSWORD

(lifted directly from the documentation)

Other than the spacing though, my configuration is basically similar to yours. If fixing the spacing doesn’t do it, you may need to raise an issue.

Thank you for the help :slight_smile: