No Access after upgrading to HA OS 2023.1

Hi all,

This morning I did an upgrade on my Home Assistant Yellow to 2023.1, normally its like 5 minuts to be done. This time it kept being unreachable after the upgrade, even after an hour and an hard reset still no access. Ofcourse I did not set up the SSH or back-ups yet so hoping to recover it somehow.

It looks all to be okay in the observer, also my Nginx Proxy Manager still works if i access it via port 80 or 443. But when I go to the normal port (8123) I get ERR_CONNECTION_REFUSED. Tried to:

  • disable the port rules on my Dream Machine
  • Access via HTTP/HTTPS
  • Access via direct IP
  • Access via Local DNS http://homeassistant.local:8123/
  • Access via Dns set up via DUCK DNS
  • Other browser
  • Other device(s)

but no results yet.


Anyone any clue whats going on? :slight_smile: Thanks in advance.

Do you have ip bans setup? If so try from another computer.

Also from other PC/Mobile Phone and external from network also no effect :(.

Long shot… How about a different browser? Maybe something is blocking the page from loading. I always keep one browser I never use (Edge) free of plugins and where I can easily clear cache without any hassle of logging back in to everything for such tests.

No also tried that thanks for the suggestion. I also cast to Google Nest Hub Mini but they also do not get a connection. So think has to do with the port on the Home Assistant itself somehow.

Have you tried a port scanner to see which ports are active?

Edit: I would also research the Unifi forums for a cause… as an example they just released a beta AP firmware that fixes connectivity to RPIs connecting via wifi. Not saying it is your case, just that Unifi has plenty of weird issues. All my network gear is Unifi and I’ve had several such cases.

Good one, 80, 81 and 443 are open. However 8123 is not:

Weird thing is that is happend after the upgrade :expressionless:

I have 23 open ports on my install of HA, most of which I was unaware of and have no clue what they are for. Even with a fresh install I would expect a few more open ports.

Are you certain that no other device may have taken the IP? I am assuming that your Yellow was set up via DHCP but with a static address. Did you happen to move stuff around, and maybe some other device, previously on that IP, may be squatting there causing trouble?

Is there any way to get the MAC of that device and see if it matches the MAC of your Yellow?

Edit: I wonder whether the Yellow has a Console output on the USB C port that spits out any messages that can help you diagnose the issue. Also, if you do a google search with ERR_CONNECTION_REFUSED and home assistant there are tons of threads in these forums about this issue… but there are also tons of potential causes judging by what I have reviewed.

1 Like